1. Norrad's Avatar
    Hello all,
    Iím wondering if anyone might be able to shine some light on what it is Iím doing wrong or not doing at allÖ

    I have a Blackberry 8330 and trying to downgrade it from 4.5 to 4.3 with no luck. I started out with DM 5.0 and downloaded two different versions of 4.3 from blackberry.com. I downloaded JL_Cmder to wipe the phone with, and did the following steps.

    1. Backed up my phone then used JL_Cmder to wipe the phone out. It now has the white screen with 507 on it.
    2. I installed the first version (123) of OS 4.3 then deleted the vendor.xml file out and ran the apploader.exe. It recognizes the phone and shows the 4.3 OS to be loaded up, but when I try to click next to install it pops up a screen saying it can not continue because the email application is missing some modules.
    3. I then uninstalled the version 123 OS and installed the next one (127). I did the above steps again with the same result about email application.

    I did this also with the current version of 4.5 and the same thing happens. After all of this I went back and downloaded DM 4.3 tried it with a different result. It just tells me no software is available for my device. I tried DM 4.5 and the same thing.

    Thanks for any and all help.
    08-17-09 08:54 PM
  2. GooTz66's Avatar
    Hello all,
    Iím wondering if anyone might be able to shine some light on what it is Iím doing wrong or not doing at allÖ

    I have a Blackberry 8330 and trying to downgrade it from 4.5 to 4.3 with no luck. I started out with DM 5.0 and downloaded two different versions of 4.3 from blackberry.com. I downloaded JL_Cmder to wipe the phone with, and did the following steps.

    1. Backed up my phone then used JL_Cmder to wipe the phone out. It now has the white screen with 507 on it.
    2. I installed the first version (123) of OS 4.3 then deleted the vendor.xml file out and ran the apploader.exe. It recognizes the phone and shows the 4.3 OS to be loaded up, but when I try to click next to install it pops up a screen saying it can not continue because the email application is missing some modules.
    3. I then uninstalled the version 123 OS and installed the next one (127). I did the above steps again with the same result about email application.

    I did this also with the current version of 4.5 and the same thing happens. After all of this I went back and downloaded DM 4.3 tried it with a different result. It just tells me no software is available for my device. I tried DM 4.5 and the same thing.

    Thanks for any and all help.
    First question is why are you trying to go back to 4.3 from 4.5?
    08-17-09 09:10 PM
  3. Norrad's Avatar
    To be able to force roam.
    08-17-09 09:19 PM
  4. GooTz66's Avatar
    To be able to force roam.
    Gotcha. Well I would start over completely from scratch by deleting all OS's from your computer and then download the latest 4.3 build onto your computer then to your device by using apploader rather than DM. You did say that you wiped to 507 correct?
    08-17-09 09:27 PM
  5. Norrad's Avatar
    Gotcha. Well I would start over completely from scratch by deleting all OS's from your computer and then download the latest 4.3 build onto your computer then to your device by using apploader rather than DM. You did say that you wiped to 507 correct?
    Yes, did wipe it out to the 507 screen (sitting this way now). I uninstalled everything on my computer, restarted it then installed the DM 4.3 Tried to install the OS 4.3 with DM and had the screen saying nothing available for my phone.. (Something along that lines)

    I'll do the uninstall again the reinstall the 4.3 and use the apploader rather then the DM this time. I'll post results soon.

    Thanks for your help,
    Rich
    08-17-09 09:35 PM
  6. xliderider's Avatar
    You can also try extracting the following .cod files from the 4.5 OS Java folder:

    All .cod files starting with:
    Net_rim_api_email
    Net_rim_bb_email
    Net_rim_secureemail

    And copy them over to the corresponding 4.3 Java folder in the 4.3 OS folder.

    Then uninstall the 4.5 OS, then load from loader.exe

    Posted from my CrackBerry at wapforums.crackberry.com
    08-17-09 09:37 PM
  7. Norrad's Avatar
    Ok...
    Installed the DM 4.3 again, then installed the first OS 4.3.0.123 (Platform 3.1.0.70). Started loader.exe, navigated to the folder where the OS installed and selected all files as soon as I click insert I get the error "No additional applications designed for your device were found.". Uninstalled that OS then installed 4.3.0.127 (Platform 3.1.0.73), got the same error.

    I can try what you suggested xliderider.
    08-17-09 09:58 PM
  8. xliderider's Avatar
    Started loader.exe, navigated to the folder where the OS installed and selected all files as soon as I click insert I get the error "No additional applications designed for your device were found."
    What does this mean? When you load an OS from loader.exe, there is no selecting all files and clicking insert, involved.

    It either detects the OS to be loaded or it doesn't.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-17-09 10:06 PM
  9. Norrad's Avatar
    When I start loader.exe it reads device service information etc. then I get a screen with nothing in the box. If I click browse then navigate to the OS directory I can select the files then click insert and it will show the OS 4.3
    08-17-09 10:23 PM
  10. Norrad's Avatar
    It either detects the OS to be loaded or it doesn't.
    So maybe this is the problem? I was just loading the files with the "add" button on the loader.exe screen.
    08-17-09 10:34 PM
  11. Norrad's Avatar
    Anyone know why the loader.exe wouldn't recognize the OS that is installed? It shows under the add/remove programs.
    08-17-09 11:16 PM
  12. xliderider's Avatar
    This worked for me, once. In the apploader folder, move the device.xml and device.xml.backup files to a new folder named "device xml files". Doing this allowed the apploader launched from loader.exe to detect my PIN and load my OS.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-17-09 11:27 PM
  13. Norrad's Avatar
    This worked for me, once. In the apploader folder, move the device.xml and device.xml.backup files to a new folder named "device xml files". Doing this allowed the apploader launched from loader.exe to detect my PIN and load my OS.

    Posted from my CrackBerry at wapforums.crackberry.com
    Tried it with no success... Thanks for all the help anyhow.
    08-17-09 11:40 PM
LINK TO POST COPIED TO CLIPBOARD