1. evicktd's Avatar
    When I received this BB 8900, it was on 4.6.1.231 OS and I couldn't send SMS messages, but could receive them. I could send MMS and everything else was fully functional.

    I figured it was an OS problem and upgraded to 5.0.0.592, but still no luck.


    I guess I'm a complete novice at this since the last BB I owned was the Pearl and that was two years ago, so is there a way I can clean the whole device and put everything back to factory settings and start from the ground up?

    Would this tactic solve my issue, anyway?

    Thanks a lot guys
    05-23-10 04:11 PM
  2. Ahmed G.'s Avatar
    go to > options, security options, security wipe

    I don't know if there is another way to wipe your BB . . plus, I'm not sure if it will solve your problem

    Maybe your SMS settings are not set properly
    05-23-10 04:29 PM
  3. evicktd's Avatar
    go to > options, security options, security wipe

    I don't know if there is another way to wipe your BB . . plus, I'm not sure if it will solve your problem

    Maybe your SMS settings are not set properly

    You're right, I did BrickMyPhone and reinstalled the OS and I still can't send SMS. How might I set my SMS settings properly?
    05-24-10 02:34 PM
  4. evicktd's Avatar
    This is very weird. I just opened the full menu and clicked on "show recipients" and it says, "No SMS Services. You will only be able to Save Draft." This is an AT&T 8900, how come it did not come with SMS text? Has this problem EVER risen because I cannot find a solution all over the internet
    05-24-10 02:50 PM
  5. Radius's Avatar
    I had this problem once, maybe it's the same reason.

    I could receive but never rend SMS. However if I replied to a sent one it would work.

    Turns out I entered all numbers as 1-xxx-xxx-xxxx and the carrier would only accept it without the leading 1 in the number. Took me a month to figure that out.

    Hope this helps.
    05-24-10 03:06 PM
  6. evicktd's Avatar
    That's not it...I can't even reply to a received SMS...Thanks though
    05-24-10 03:30 PM
  7. superfestiva's Avatar
    this happened to me but not with that error message....what I did was in the phone options - put the smart dialing number as unknown and voila....never happened since....
    My $.02....

    Posted from my CrackBerry at wapforums.crackberry.com
    05-24-10 09:24 PM
  8. evicktd's Avatar
    this happened to me but not with that error message....what I did was in the phone options - put the smart dialing number as unknown and voila....never happened since....
    My $.02....

    Posted from my CrackBerry at wapforums.crackberry.com

    Where did you find phone options? This problem STILL hasn't been solved, I'm getting very frustrated
    05-25-10 12:33 PM
LINK TO POST COPIED TO CLIPBOARD