1. kyle6279's Avatar
    For the last week I have been having problems with my battery on my 8310 Curve.

    The first time I noticed, I had about 40% of my battery left and I was using messenger and the phone just died. I turned it back on to see that it showed 0% of the battery left. I recharged it to about 60% and later on it did the same thing.

    It has done this on and off throughout the week. Today it took my battery about 3 hours to go from 100% to 60%. I only looked at one email and one SMS today. There are no apps open in the background either.

    I upgraded to v4.5.0.52 about a month ago and everything has been fine until now. I also did the upgrade for my brother's and my dad's 8310s and they have no problem.

    Is anyone else having this problem? Is it the battery or the phone? Someone please help me out. Thanks guys
    09-11-08 11:51 AM
  2. abeberness's Avatar
    I would say its the battery on your particular phone. Try replacing the battery.
    09-11-08 11:53 AM
  3. kyle6279's Avatar
    One more thing I forgot to mention. Two days ago I noticed that when the battery is at about 50% the speakerphone will start to have a crackling sound and without speakerphone I start to hear a buzzing in the background. Almost like when you put your phone too close to a computer speaker or something. Any ideas?
    09-11-08 11:56 AM
  4. abeberness's Avatar
    How long have you had this curve?
    09-11-08 11:58 AM
  5. kyle6279's Avatar
    Since last November, I've never had a problem until now.

    Could it be the OS upgrade for some reason?
    Last edited by kyle6279; 09-11-08 at 12:09 PM. Reason: more info
    09-11-08 12:04 PM
  6. kyle6279's Avatar
    anyone else having this problem?
    09-12-08 09:26 AM
LINK TO POST COPIED TO CLIPBOARD