1. turbo_tim's Avatar
    ive been getting this error on my 8350i .128. and since it hasnt been saving my recent two ways, therefore i cant tell if anyone has two wayed me. does anyone know the fix or has anyone else had this?!
    uncaught exception: java.lang.nullpointerexception
    02-28-09 11:34 AM
  2. Cobra1100's Avatar
    Tim,

    I had the same thing happen to me after trying a few of the new themes posted. Not sure if that had anything to do with it or not, but I uninstalled the themes and restarted the BB and it hasn't happened since.

    This didn't happen just from trying the themes, though. I was listening to MP3's through the bluetooth and tried to go back to my recent calls and that is when I got the error message. Same error message you got. As long as I didn't try to listen to the music, it didn't give a problem, but every time I listened to music and then hit the green button, I would get the error.

    I'm hoping that this came from the Plazmic beta and will be resolved when the final release is out. These guys have made some awesome themes and I'd love to use some of them again.

    I've got the Plazmic 4.7 that was posted a few weeks ago and the ones I made myself also caused the same error, so I can't use my own themes, either.

    If you haven't downloaded any of the themes and are still getting that error message, I don't know what to tell you. Mine didn't start the error when trying to look at recent calls until I installed a couple of them, and the two that I made myself. Then, it only did it when I had the music playing, not if I just tried to go to the recent calls.
    02-28-09 11:43 PM
  3. turbo_tim's Avatar
    cobra,
    It must be something else, i haven't installed any themes. I first got the error when someone beeped me a few days ago. If i reboot, the error shows up first thing. The only thing that i have done to it in the last week or so was install the flashlight app a couple days before i got the error. Do you know if i can uninstall the app and reinstall it w/o buying it again? I've read about a lot of problems with this phone, i got one of the first ones in early jan. and haven't experienced any of the problems that anyone talks about(just thought i was lucky). I've been very happy with it until this. Thank you for the help, i thought i was the only one out there with this error.

    -Tim
    03-01-09 12:02 AM
  4. Cobra1100's Avatar
    Tim,

    I don't know about the flashlight app. I'm glad to hear that it wasn't the themes, though. I've not heard of anyone else in the themes threads saying anything about it, that was the reason I never posted anything about it there.

    As far as the flashlight app, did you download it with your BB or to your computer and then install? If you downloaded to your PC, then your license info should be in the download, I would think.

    One other thought, you may want to look through the threads about reinstalling the upgrade. Maybe that would fix the problem? Sorry I can't be of more help.
    03-01-09 12:29 PM
  5. alex63's Avatar
    Here is another thread I found dealing with this problem.

    Might offer some suggestions:

    http://forums.crackberry.com/f86/unc...eption-155452/
    03-01-09 12:54 PM
  6. Cobra1100's Avatar
    Alex,

    You are the man. I really appreciate everything you do to help us all out here. I tried every search string I could think of (except the obvious) and couldn't find anything. I had thought it had something to do with the themes, since I didn't get it until the day I installed a couple. I'm gonna go try them again.

    Thanks again, Alex!
    03-01-09 04:04 PM
  7. turbo_tim's Avatar
    Thank you for the help Alex, i am still wondering if anyone got the error fixed or not. Maybe I'm wrong but it sounds to me like the problem was an os issue. All of the people with the problem were running .75. Cobra did u recently install .128? and have you found a fix yet. I am new to bb's and not sure i know exactly how reinstall my os yet, but if it fixes the problem i'll give it a shot.
    Thanx for the help again guys.
    -Tim
    03-01-09 10:45 PM
  8. turbo_tim's Avatar
    Cobra, as far as the flashlight app i downloaded it from my bb, but i believe i still have the email with the link to the download.
    03-01-09 10:46 PM
  9. alex63's Avatar
    Happy to help guys,

    Digging a little deeper, it seems that something is corrupted in the call log. Here is how a member named Taskbar resolved it.

    Source is form this thread:http://forums.crackberry.com/f86/cal...eption-161930/



    Hi guys,

    I have a problem with my Blackberry Storm and the call log. Incoming calls are being logged, but outgoing calls are not being logged.

    Now here is the troubleshooting steps I have taken:

    1. From the Storm main screen, I press the "SMS and MMS" icon
    2. I press the blackberry button
    3. I select "View Folder" link
    4. I select "Phone Call Logs" link

    Now after about 1.5-2.0 seconds, I get a popup that states:

    "Uncaught exception: java.lang.NullPointerException"

    w/the OK button

    5. I press the OK button, and the message goes away.


    Ok, with me so far?

    When I open the call logs the normal method, by:

    1. Press the green phone button on the Storm
    2. Press the call log icon
    3. It displays the calls but if I dialout on a number, it does not show the call.


    By the way, one other thing, I get the error message every time I boot up my telephone. This started on Thursday of last week. I have not installed any other software during this same time period and the "Call Log" was working fine ever since I received my Storm back in December.

    Any ideas???

    Thanks so much in advance.




    ====================
    UPDATE: I have resolved my issue.... for me it turns out that my call log database on the Storm was corrupted. I determined this by:

    1. Open main blackberry screen
    2. Select "SMS and MMS"
    3. Press the blackberry button
    4. Select "View Folder"
    5. Select "Phone Call Logs"
    6. Then it would give me the java exception error message

    I then did the following to resolve it for me:

    I connected Storm to desktop PC. I ran a backup of my Storm to the desktop computer using the Blackberry Desktop Manager sofware. Once the backup completed, I clicked on "Backup and Restore", then clicked on "Advanced" and over on the right-hand side of the screen, I scrolled down to locate "Call Log".... I selected that, and then pressed the "Clear" button at the bottom. I then went to the steps I listed above in this post, and no more Null error message. And now my call logs are back working, woohoo!!!

    Taskbar
    ====================
    03-01-09 11:01 PM
  10. Cobra1100's Avatar
    Sorry Tim,

    We just had a snow storm and I had to go in and work a few hours.

    I am running .128 and only have a couple apps on my phone. My errors started the same day that I tried a couple themes posted here. I was listening to music, had the music player hidden and went to make a call from my call log, and the phone locked up with the uncaught exception.

    I did a battery pull and reset the phone and all was fine until I started listening to music again and tried the call log. That is why I thought it may have something to do with the themes. But, this is different from yours in that yours gets the error anytime you try the call log.

    Alex's research shows the most probable solution to your issue. At least the only thing you will lose is the call log if you try it. And, since you can't get to the call log anyway, you're not really losing anything that you haven't already lost. If mine were still giving me the error, I would try this to see if it clears it up.

    I will say this, I have since re-installed the themes and everything is working great now. Maybe I had some corruption in my call log that somehow got cleared from a battery pull.

    Thanks again, Alex, for all the research, lending your expert advice and for being as friendly to everyone as you are.
    03-02-09 02:53 AM
  11. turbo_tim's Avatar
    Alex and Cobra thank you for all of your help, i have found that the problem is in my direct connect call log, when i go into desktop manager, backup and restore, advanced, i dont see an option for direct connect call logs so i still have the problem, but my phone does record phone calls just not two ways. any ideas?
    -Tim
    03-02-09 06:50 PM
  12. alex63's Avatar
    Do you have call logging on for 2 way?
    Green phone button>menu>options>call logging

    Posted from my CrackBerry at wapforums.crackberry.com
    03-02-09 07:54 PM
  13. turbo_tim's Avatar
    my options are: missed calls, all calls, all calls no direct connect, none. it has been set on all calls. another thing is when i tried a backup it failed.i will see where its at when it fails and let you know.
    03-02-09 11:19 PM
  14. turbo_tim's Avatar
    i think i'm going to reload my os
    03-02-09 11:29 PM
  15. alex63's Avatar
    Yeah reload it's really not that hard to do. Just backup your stuff and your 3rd party apps.
    read this if you need info on how to backup 3rd party apps.
    http://forums.crackberry.com/f3/upda...updated-53201/
    03-02-09 11:46 PM
  16. Cobra1100's Avatar
    Tim, one other thing on the backup. If you have your BB set to Mass Storage Mode, it can't do a complete backup. When you connect to DM, make sure you say NO to Mass Storage Mode before starting the backup. Try that and see if you can get it to backup correctly. That may give you access to the call log through the DM.
    03-02-09 11:48 PM
  17. turbo_tim's Avatar
    i can't even back the dreaded thing up anymore... i have a backup from about 5 days ago so it should work. thank you for your help alex and cobra
    03-03-09 05:01 PM
LINK TO POST COPIED TO CLIPBOARD