1. vtsang's Avatar
    It's come to my attention that majority of the replacement housings from ebay, including those from GSM4WORLD (in short, ones that are not OEM) do not include the foam gasket between the LCD and the lens on the housing which keeps out the entry of dust. I was wondering if the black foamy double sided tape available for purchase from local hardware stores would do the job, or would they be too thick? Has anyone tried this before?

    Also, I've noticed from some posts that the notification LED cover may also missing on the replacement housing. If this is the case, would the LED cover from the 8320 fit for the 8330 housings?

    Your help will be much appreciated.
    03-27-09 07:19 AM
  2. xliderider's Avatar
    Yes, the foam tape from hardware stores is much too thick. The LED works fine without the LED cover.
    03-27-09 08:08 AM
  3. rachel0179's Avatar
    You can use the plastic LED cover from the 8320, all it is a little plastic plug thing, pop it off the old, and pop back into the new 8330.
    03-27-09 08:18 AM
  4. xliderider's Avatar
    You can use the plastic LED cover from the 8320, all it is a little plastic plug thing, pop it off the old, and pop back into the new 8330.
    I believe ppl use a needle nose plier to pull the LED cover off the faceplate, but you need some kind of glue to attach it to the new faceplate.
    03-27-09 08:23 AM
  5. rachel0179's Avatar
    Nope, not on mine, it has little attachment things, I used my tweezers to pull itoff, and it just pops right back on, it has the little things like a jigsaw that you just attach too, no glue needed for the led cover, its a plastic plug thing.

    Well, that was when I had the 8320.. its easy, no pliers or glue involved, the 8330 may be different, I havnt taken this one apart yet to see, but anyways
    03-27-09 08:25 AM
  6. xliderider's Avatar
    I know what you're referring to. My Verizon OEM cover has the two post-like things sticking up from the faceplate to hold the plug, but my black faceplate I got from gsm4world didn't.
    03-27-09 08:30 AM
  7. rachel0179's Avatar
    I had not one, but two terrible experiances with gsm4world, I gave them a second chance, I wont order from them again. Much better quality items elsewhere IMO
    03-27-09 08:33 AM
  8. xliderider's Avatar
    Why bother? The LED works fine without the diffuser/cover.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-06-09 10:48 PM
LINK TO POST COPIED TO CLIPBOARD