09-29-09 08:07 AM
65 123
tools
  1. Kendall Paris's Avatar
    Hello,

    I'm a longtime BlackBerry user, so I have some idea of how to use it. However, the person that I just bought the 8350i from hasn't a clue about one.

    He bought a phone from a guy that supplies them to businesses, so it had never been activated. He initially had a Boost SIM in the phone and it was working just fine. At some point, another friend of his tells him about how he can get on the internet and I suppose he was trying to turn it into a BoostBerry.

    He says that he was pushing various buttons and at some point, did something that permanently disabled the phone. Every time we go into Manage Connections, the checkmark appears and then disappears quickly. The red X stays there.

    I have been able to get online through WiFi and I've loaded the BoostBerry service books. After I did that, the Maps icon showed up and the icon that previously only said SMS, now says SMS and MMS, so from what I can tell, it is only the phone that's broken.

    I'm thinking that the problem is due to there being no entries under the Host Routing Tables, but I can't get any real assistance from Boost because they don't officially support the BlackBerry and Nextel is saying that the HRT has nothing to do with it and they can no longer troubleshoot a Nextel phone with a Boost SIM.

    So, what I need to know is:

    1. BoostBerry owners, do you have any entries under the Host Routing Tables screen? If so, is it for Boost or Nextel?

    2. If it is because of the HRT entries, how would I go about getting them back?

    3. What else could it be?

    4. What the heck did he do?
    09-06-09 07:26 PM
  2. Casper34's Avatar
    what i would do is put in a working nextel sim, one from another blackberry. let it connect, try everything, then follow the boostberry sticky.
    09-06-09 07:34 PM
  3. Kendall Paris's Avatar
    Can it really be that simple? Either way. Thank you. I'll let you know if it works.

    By the way, is the problem connected to the tables?
    09-06-09 07:36 PM
  4. Casper34's Avatar
    dont know, but if you put in a working nextel bb sim and it works, then you should just be able to load the service books from the sticky and all should be good... no if it does not, it sould like the phone is locked, you would have to take it to a nextel store to repair it, if possible
    09-06-09 07:40 PM
  5. Kendall Paris's Avatar
    Okay, usually when I hear the term "locked," it means that only one carrier can use it. Are you saying "locked" in that regard or do you mean that somehow he has locked up the phone in another way.

    Because I've already loaded the service books from the sticky and everything is working fine. Everything but the phone.

    There aren't any service books that correlate to the phone, right?
    09-06-09 07:48 PM
  6. Casper34's Avatar
    no as in a security lock....

    without service books, the phone does not know what to do, sorta speak
    09-06-09 08:29 PM
  7. Kendall Paris's Avatar
    Okay. First, thanks for your willingness to try to work me through this.

    Second, is there any way that I would be able to unlock a security lock or do I have to take it in?

    Third, is there a service book for the phone? Is that the one that I would need?
    09-06-09 08:40 PM
  8. piloso's Avatar
    Okay. First, thanks for your willingness to try to work me through this.

    Second, is there any way that I would be able to unlock a security lock or do I have to take it in?

    Third, is there a service book for the phone? Is that the one that I would need?
    I don't know much about that but have you tried the following...
    Options>Avanced Options>Applications>Scroll down to phone and select it>press menu>Edit default permissions:
    connections=allow
    interactions =allow
    user data=allow
    09-06-09 11:08 PM
  9. Kendall Paris's Avatar
    Thank you! I've gone in and changed those things. The phone is still not working, but I think I'm getting closer. Now, I think that the problem is that somehow, he deleted the phone modules.

    I'm looking through the list under BlackBerry 4.6 Core Applications Properties and I don't see the two modules that are listed when I looked under phone to change the permissions.

    net_rim_bb_phone_api and net_rim_bb_phone_app seem to be missing from the list. Am I correct in believing that those two things are needed?

    If so, how do I go about getting them back and would you be able to tell me what the entries under your Host Routing Tables say? Is it a long list of Boost or Nextel?

    Thanks again for your help.
    09-07-09 07:56 AM
  10. piloso's Avatar
    Thank you! I've gone in and changed those things. The phone is still not working, but I think I'm getting closer. Now, I think that the problem is that somehow, he deleted the phone modules.

    I'm looking through the list under BlackBerry 4.6 Core Applications Properties and I don't see the two modules that are listed when I looked under phone to change the permissions.

    net_rim_bb_phone_api and net_rim_bb_phone_app seem to be missing from the list. Am I correct in believing that those two things are needed?

    If so, how do I go about getting them back and would you be able to tell me what the entries under your Host Routing Tables say? Is it a long list of Boost or Nextel?

    Thanks again for your help.
    if your phone is missing those two modules very likely that is what is causing your problem. Have you done a WIPE HANDHELD? that could put your device to factory default.
    09-07-09 11:26 AM
  11. Kendall Paris's Avatar
    Well, I have done a wipe handheld and the phone still isn't working. Although, it does look like I've seen a few things in lists that I hadn't seen before, so I'll keep trying.

    I'm thinking that I may wipe it completely next. What have I got to lose, right?
    09-07-09 03:24 PM
  12. Casper34's Avatar
    what OS is on it? you may want to try and update it.
    09-07-09 04:23 PM
  13. Kendall Paris's Avatar
    It's on the very latest, 4.6.1.204 and I've tried to update it. I'm thinking that I should wipe it completely to see if I can reload the phone.

    I'm grasping at straws at this point. No one can tell me what the entries are under their Host Routing Tables, so I don't know if that's the problem and if it is, I don't know how I would get the entries.

    I just can't imagine what he could've done to disable the phone. I may post this up on another board or two and pick more brains, because this is a stumper.

    He's done the almost impossible: killed a BlackBerry.
    09-07-09 04:37 PM
  14. Kendall Paris's Avatar
    Well, now I've done it. I can't get it to reload the OS. I'm in the process of reading the "Nuked Berry" tutorial, but I don't think I've ever been this frustrated by a Berry.

    This is wild.
    09-07-09 05:55 PM
  15. Casper34's Avatar
    C:\Program Files\Common Files\Research In Motion\AppLoader\loader.exe

    use this
    09-07-09 06:38 PM
  16. Kendall Paris's Avatar
    Wow. I guess it's over. I got this in the very early stages of trying to load the OS using the Nuked Berry instructions.

    Device communications error encountered. [A:0x0000000F]

    Now, I'm kind of depressed. The phone was a want, not a need and now the entire unit has been destroyed. Everything but the phone was working and I should've let it be.

    Thanks for your help, but I'm at a loss.
    09-07-09 08:04 PM
  17. Casper34's Avatar
    if thats the case then reload the software.... follow the instructions on how to wipe your bb using JL and start all over
    09-08-09 05:32 AM
  18. Kendall Paris's Avatar
    I have already wiped it with JL, that's the point I am at now. I have wiped a Berry before, so I was willing to do it, but it was never this difficult to get the software back on.

    Do you think whatever made it so difficult to get the phone back working is the same obstacle with me reloading the software?
    09-08-09 06:46 AM
  19. Casper34's Avatar
    i doubt it... are you using JL to load the OS back on or are you using the Loader.exe?
    09-08-09 07:04 AM
  20. Kendall Paris's Avatar
    I used JL to wipe. I initially used the DM to reload and it would give me the fatal error message. Then, I started using the loader.exe from your suggestion and the Nuked Berry article. That's when it gave me the specific device communications error.

    I even, at someone else's suggestion, removed the vendor.xml when trying to reload under the loader.exe. Same message. I took off everything that had XML labeled and still the same device communications error.

    I've also tried going back through the DM and doing a software update, granted that way stayed in the process longer, but in the end, it gave me the original fatal error message.

    Would you suggest trying on another computer or something? I've switched USB hubs and when I say hub, I mean internal hubs, not external.
    09-08-09 09:36 AM
  21. Casper34's Avatar
    try another computer, also check to see if the usb port is being turned off
    09-08-09 09:45 AM
  22. ibbeach0's Avatar
    Just a shot in the dark but do you have "NXTL" or "NXtl"?
    09-08-09 10:06 AM
  23. Casper34's Avatar
    one restored check to see if you have this.... if it does not work.....

    menu
    options
    advanced
    applications...... scroll to see if you have an app called phone
    09-08-09 10:13 AM
  24. Kendall Paris's Avatar
    Okay, I'll try another computer. Probably won't be able to do that until tomorrow, though.

    @ibbeach: I don't recall what the guy who owned the phone had before me. I know that he was using a Boost SIM and that the phone was working, but I never looked to see whether it said NXTL or NXtL.

    I never looked at the Berry in detail until he actually did something to disable the phone. After that, there was nothing. It just constantly said off and we could never get it to turn back on.

    I was trying to reinstall the OS, thinking that somehow he deleted it off.


    back @casper: when the Berry was still alive, I did have an app for phone. I even changed the permissions as suggested earlier in the thread. And when I would try to reload, it was checked off and greyed out, but at that point, I couldn't reload anything.
    09-08-09 10:32 AM
  25. Kendall Paris's Avatar
    I've been trying to use the directions in the How to Recover a Dead Berry thread, but even after it does the initial force through, it will not load the software.

    Any other suggestions? I'm on a different computer, I'm using a back USB port, I have a brand new connection cable. What else can I do? Casper, you mentioned making sure the USB port was not turning off, how do I monitor that?

    Is this Berry salvageable?
    09-09-09 11:26 AM
65 123
LINK TO POST COPIED TO CLIPBOARD