1. erimfranci's Avatar
    Hey guys, I bought a Curve 8900(by Movistar) from Canada. I got the unlocked one and I'm using it in Turkey. However the edge wont work. The "edge" symbol in the right corner wont go capitilized(EDGE) so I cant use my blackberry messenger and the internet. I tried to load a turkish carrier's OS but it didn't work. Whats the problem???
    08-15-09 06:32 AM
  2. lazerus's Avatar
    Perhaps the signal is not strong in that area. Call your carrier and see. The os would not make a difference.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 06:40 AM
  3. Symp EL's Avatar
    My wifes did the same thing. It was because ATT didn't activate data on her line.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 08:12 AM
  4. erimfranci's Avatar
    so no solution?
    08-15-09 08:36 AM
  5. Symp EL's Avatar
    Call your service provider and see if the correct data plan is activated.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 08:41 AM
  6. erimfranci's Avatar
    yes it is activated.
    08-15-09 08:52 AM
  7. Symp EL's Avatar
    Probably week signal then.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 08:54 AM
  8. aristile's Avatar
    Is the device unlocked? You need to unlock it first since you purchased the device from a carrier different from the one you are using it on.
    08-15-09 12:44 PM
  9. KurtisBertolami's Avatar
    Yes aristile he said it was an unlocked one

    Posted from my CrackBerry at wapforums.crackberry.com
    08-15-09 06:24 PM
  10. larrygump's Avatar
    Ok so if its unlocked he's gonna need his carriers service books for data....that's what it sounds like....search "edge storm" and use the storm thread to get the step by steps on how to change your books

    Posted from my CrackBerry at wapforums.crackberry.com
    08-16-09 08:46 PM
  11. larrygump's Avatar
    Ps I can't see if he's with tmo cuz I'm on my bb but if he's not he's gonna need to find em...

    Posted from my CrackBerry at wapforums.crackberry.com
    08-16-09 08:47 PM
  12. erimfranci's Avatar
    I tried the service book thing but nothing changed. I can't even register to BIS. It says "Your BlackBerry® Internet Service Account is suspended or deactivated. "
    08-17-09 06:20 AM
  13. amrishpatel54's Avatar
    This is data service issue.. Check with your service provider..
    08-17-09 06:54 AM
  14. larrygump's Avatar
    i concur.......
    08-17-09 11:07 AM
LINK TO POST COPIED TO CLIPBOARD