1. maggif's Avatar
    I've done alot of searching and this seems to be asked alot without a definitive answer.

    I purchased an 8900 of ebay that was supposed to be unlocked from T-Mobile UK, however it simply says invalid sim card -sos mode with the several sim cards tried. I've tried to check or get it unlocked if needed by going to Advanced Options-Sim Card but theres nothing there, just 'No Valid Sim Card'.
    I'm trying to use it with an Optus Australia sim.

    I'm a bit stuck and here and am contemplating asking for a refund if I can't get around this but the seller is not responding.
    10-24-10 01:19 AM
  2. mynameismerlin's Avatar
    Sounds like the phone is not really unlocked. You will need to use the phone's original carrier SIM card (T-Mobile UK) to get to the menus needed to unlock the phone. You might want to contact one of the companies that post on the forums here for unlock advice.
    10-25-10 11:04 AM
  3. emerald88's Avatar
    I encountered the same problem when I bought my 8900,when you're in advanced options go to sim card and type in mepd,if any of the options say enabled it isn't unlocked.Like merlin said there's a ton of unlocking companies on here and they're more than happy to help

    Posted from my CrackBerry at wapforums.crackberry.com
    10-25-10 12:51 PM
LINK TO POST COPIED TO CLIPBOARD