1. Sypheron's Avatar
    Hi all.
    I just received my 8900 Curve today, and I've been trying to set up and install all kinds of different applications already.
    I'm with T-mobile in the Netherlands, and I have an unlimited dataplan with BIS.

    The problem is though, if I go into the Setup -> Setup Wizard -> E-mail setup menu, it only shows me "I want to use a work email account with a BlackBerry Enterprise Server".

    I checked the whole machine, and there is no other way of adding a normal e-mail adress at the moment. I phoned T-mobile, and they told me to install the software that comes with the CD. Eventhough I doubted this would help, I tried it. I just wanted to phone them to tell them it didn't work, when I heard that the servicedesk is closed now...

    Is there anyone that has experienced similar problems?

    Thanks in advance!
    05-16-09 12:03 PM
  2. Rob#CB's Avatar
    Same goes here...just got my Curve II today and nothing yet on the different email.
    I'll keep searching.
    05-16-09 08:32 PM
  3. Studentb's Avatar
    I've got the same problem, got my BB 8900 last week and still waiting for the carrier transformation to take place.
    I thought I can't configure any emails because I don't have the data plan yet.. but I guess maybe it's something more.
    My only option is that BIS account as well.
    I'm using my BB in Italy, maybe something is wrong here in Europe.. don't know..
    any ideas how to fix it? maybe we should update the OS??
    05-17-09 04:30 AM
  4. savioAMG's Avatar
    Those of you that are trying to add a personal email account, are you on a BIS data plan?
    05-17-09 04:39 AM
  5. laurag84's Avatar
    You need to go to your carrier's BIS website and set up your emails that way.

    The best way to find it is to do a google search. For instance, my carrier is o2 UK so I would search for 'o2 UK BIS'. It'll usually be one of the top search results, and all you need to do is follow the instructions to set up an account and then set up your emails.

    I hope this makes sense, let me know if not!

    Posted from my CrackBerry at wapforums.crackberry.com
    05-17-09 04:43 AM
  6. chitown2's Avatar
    I'm having the same problem. Im trying to setup BIS email on new replacement T-mobile Curve 8320. I've already setup the account on t-mobile's site. When I go into the Setup Wizard , I'm only given the option to setup a BES account.

    Any clue?
    05-20-09 05:55 PM
  7. Studentb's Avatar
    You need to go to your carrier's BIS website and set up your emails that way.

    The best way to find it is to do a google search. For instance, my carrier is o2 UK so I would search for 'o2 UK BIS'.
    Posted from my CrackBerry at wapforums.crackberry.com
    I've tried setting up the emails from the carrier's BIS website and it works like a charm!! thanks so much! you've just made me realize what BB is all about, my first ever Blackberry and I can't stop loving it now with the emailing issue settled and running!
    It all suddenly came to life, I'll be dammed.

    The moment I set it up on my the carrier website I saw the BIS option for the first time.. try send Service Books, i dont know what is doing but it helped me....
    05-20-09 07:42 PM
  8. Rob#CB's Avatar
    Ditto, when they set up my account it was originally for an iPhone and when I went back to Blackberry the forgot to change the service..all good now...
    05-20-09 09:31 PM
  9. patrovitta's Avatar
    You need to go to your carrier's BIS website and set up your emails that way.

    The best way to find it is to do a google search. For instance, my carrier is o2 UK so I would search for 'o2 UK BIS'. It'll usually be one of the top search results, and all you need to do is follow the instructions to set up an account and then set up your emails.

    I hope this makes sense, let me know if not!

    Posted from my CrackBerry at wapforums.crackberry.com
    I have the same problem but went to carrier's bis page and got an "invalid imei or pin / contact your carrier" message, I tried by upgrading and downgrading my OS and nothing... Hope you can help me. I am switching to a 8900 from a storm and when i try to make the change on the bis page it didnt work. I tried unlocking but when I go to sim everything is shown as free.
    07-06-09 02:36 AM
  10. exelant's Avatar
    On your berry try openong your Manage Internet email, this will take you to your provider's site to add email addresses. Also, you can restore a backup file you have for your storm to your 8900. Plug your 8900 in to your PC, open desktop manager and select backup restore, then restore option. Select the most recent backup file and it will add your databases like contacts and bbm contacts to your new device. Or use the device switcher if you still have your Storm. Good luck.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-06-09 05:08 AM
  11. patrovitta's Avatar
    Exelant:
    Thanks for the tip unfortunately didnt work! I dont know whats goin' on, I tried everything, downgrade, remove policies (policy.bin) Restore, switch device and seems to be blocked and only works for BES. I bought the unlock code but when reaching the unlocking menu everything is unlocked. I don't know what to do, the phone makes and receives calls and sms, but there's no way to put it on EDGE system and BIS.
    07-06-09 09:51 PM
  12. IanCognito's Avatar
    I had this issue on mine when I got it. Called my carrier (Rogers) and found out they mistakenly had me on an iPhone plan. You need to be on a BB BIS data plan. Once they switched it on their end, I was asked to turn my phone OFF and ON.

    The BIS option under email setup then appeared after restart.

    Good luck!
    07-06-09 10:54 PM
  13. Enigmata's Avatar
    Its actually great the way Tmo does the BIS website, as it is available through them, and the preserve the autologin of your device the whole time.

    Go to your account on the TMo website, and find the link to email setup (make sure that the site has your BB showing) and go deal with it. It will be availabe thru email setup on your device after the email accounts show on your device.
    07-07-09 01:06 AM
  14. HD123's Avatar
    I had the same problem, called the carrier and it turned out they had put me on a BES plan by mistake. They fixed it within a day I think.

    And if this is the problem, going to your carriers website as mentioned above wont work. You will most likely get a message that states you have entered an incorrect IMEI number.
    07-08-09 10:17 AM
  15. patrovitta's Avatar
    I give up, there is no way to make it have BIS... as far as I know there is a lot of 8900 with the same problem, I tried everything and didn't work. I decided to sell my 8900 and keep my storm. A friend needs a phone with everything that the 8900 have but she don't have a BB plan, she is crazy about the WiFi, calendar, contacts, task management, 3.2mp camera, vid recording, youtube reproduction, so, she is happy with the no able to configure bis 8900... Thank you everybody for the help!!!
    Now I am seeking for a tour device... wish me luck!!!
    07-10-09 09:24 PM
  16. Cllementine's Avatar
    You need to go to your carrier's BIS website and set up your emails that way.

    The best way to find it is to do a google search. For instance, my carrier is o2 UK so I would search for 'o2 UK BIS'. It'll usually be one of the top search results, and all you need to do is follow the instructions to set up an account and then set up your emails.

    Posted from my CrackBerry at wapforums.crackberry.com
    This worked perfectly! Thank you!
    08-04-09 11:45 AM
LINK TO POST COPIED TO CLIPBOARD