1. onemore4gsus's Avatar
    After three weeks of different NOT-fixes for my data connection which included software updates, wireless updates, and a visit to the store where I purchased my BB 8520 Curve that resulted in "there's nothing we can do to fix it," the online chat support tech fixed my data connection problem yesterday!

    Specifically, the problem was when I purchased my 8520 the EDGE connection (my local data connection) worked fine in my locale. Then the GSM icon began to replace the EDGE one, allowing voice connection but no data. The only time I could get a data connection was via Wi-Fi.

    Solution? Take out the battery pack and then put it back in. Fixed the problem immediately.

    The tech suggested doing this weekly. Sounds weird, but hey, if it happens again, I'll try that FIRST.
    07-14-10 08:50 AM
  2. mangcool's Avatar
    After three weeks of different NOT-fixes for my data connection which included software updates, wireless updates, and a visit to the store where I purchased my BB 8520 Curve that resulted in "there's nothing we can do to fix it," the online chat support tech fixed my data connection problem yesterday!

    Specifically, the problem was when I purchased my 8520 the EDGE connection (my local data connection) worked fine in my locale. Then the GSM icon began to replace the EDGE one, allowing voice connection but no data. The only time I could get a data connection was via Wi-Fi.

    Solution? Take out the battery pack and then put it back in. Fixed the problem immediately.

    The tech suggested doing this weekly. Sounds weird, but hey, if it happens again, I'll try that FIRST.
    Glad it's all working!

    And remember, almost 80% of BB problems can be fixed by just doing a battery pull.

    07-14-10 01:36 PM
  3. Solachica's Avatar
    Battery pull to the rescue yet again !!!

    Posted from my CrackBerry at wapforums.crackberry.com
    07-14-10 06:02 PM
LINK TO POST COPIED TO CLIPBOARD