1. Curious56's Avatar
    Last week I was able to browse the internet without a wi fi connection. Now my Curve tells me that the sitesI'm going to 'need a wi fi service'. Any ideas why this has happened or how I might change it back?

    thanks.
    08-20-09 02:23 PM
  2. fatboy97's Avatar
    Try this: Manage Connections > Mobile Network Options > is Connection Preferences set to Wi-Fi Preferred or Wi-Fi Only???
    08-20-09 02:26 PM
  3. cbwannabe's Avatar
    Had you switch to the Hotspot Browser? I noticed the same message. Seems like after I tried it again, it automatically switched back to the Internet Browser and the EDGE took over.
    Last edited by cbwannabe; 08-20-09 at 02:31 PM.
    08-20-09 02:28 PM
  4. Curious56's Avatar
    It's set to 'preferred'.
    08-20-09 02:29 PM
  5. cbwannabe's Avatar
    I don't see Connection Preferences under Mobile Network Options on mine.
    08-20-09 02:32 PM
  6. Curious56's Avatar
    Had you switch to the Hotspot Browser? I noticed the same message. Seems like after I tried it again, it automatically switched back to the Internet Browser and the EDGE took over.
    Not that I'm aware.
    I'm still new to Blackberry so all this is very confusing!
    08-20-09 02:32 PM
  7. fatboy97's Avatar
    I guess I should ask... what site are you trying to bring up on your phone???
    08-20-09 02:38 PM
  8. Curious56's Avatar
    I guess I should ask... what site are you trying to bring up on your phone???
    Facebook, Blackberry & the BBC (eclectic, eh??!!)
    08-20-09 02:42 PM
  9. aristile's Avatar
    Do the following:

    Options > Advanced Options > Host Routing Table > BB Button Register Now

    Then login to your BIS manager and re-send your service books to your device.
    08-20-09 02:50 PM
  10. zwood's Avatar
    Facebook, Blackberry & the BBC (eclectic, eh??!!)
    Are you using bookmarks to get to the sites or are you entering the address manually? I know it sounds stupid but humor me.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-20-09 03:00 PM
  11. Curious56's Avatar
    Bookmarks. Nothing sounds stupid to me - I just feel so at sea.
    08-20-09 03:02 PM
  12. zwood's Avatar
    Bookmarks. Nothing sounds stupid to me - I just feel so at sea.
    Try it by entering the address manually.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-20-09 03:05 PM
  13. aristile's Avatar
    Bookmarks. Nothing sounds stupid to me - I just feel so at sea.
    AH HA!!! Nice catch zwood!

    That's your problem, the Bookmarks on the BB remember the specific connection you used when they were saved. Try to go to the sites directly instead and see if they work that way.
    08-20-09 03:05 PM
  14. zwood's Avatar
    Hope you also checked to see that the browser was set to internet browser in browser configuration.

    Posted from my CrackBerry at wapforums.crackberry.com

    When you add a bookmark you can change the properties for that bookmark by clicking on the value and selecting what you want.
    Last edited by zwood; 08-20-09 at 03:26 PM.
    08-20-09 03:20 PM
  15. Curious56's Avatar
    Thank you. Will try that.
    08-20-09 05:20 PM
LINK TO POST COPIED TO CLIPBOARD