1. red33's Avatar
    I was messing around with my BB and I accidently chose a wrong option. When I try and delete my emails from the trash bin, a notice comes up and reads "gmail for mobile cant access the server until you grant it permission to send and receive data over the network". I went to my gmail account from the comp, went to settings and there is nothing that states the warning. So I guess my problem is when I chose the wrong option from the handheld, but i dont know where to go from the BB to change the setting. I hope all this makes sense. Can you help me?
    08-07-09 06:05 AM
  2. thiengom's Avatar
    I guess the problem is that your identification was failed with gmail account. Try to correct your username and password in your handheld.

    BR
    08-07-09 08:15 AM
  3. Stang07's Avatar
    Try going to options>advanced options>applications>scroll to gmail and press menu>edit permissions. make sure everything is set to allow.
    08-07-09 02:05 PM
  4. red33's Avatar
    i need to reset all permissions at least i think so. every app i go to a notice pops up and says i either need to reset the firewall or permissions
    08-08-09 06:06 PM
  5. xliderider's Avatar
    Did you make any changes to your firewall setting?
    08-08-09 06:19 PM
  6. red33's Avatar
    if i did i didnt realize it. is there a way to reset the firewall settings back to the way they were originally?
    08-08-09 06:21 PM
  7. xliderider's Avatar
    if i did i didnt realize it. is there a way to reset the firewall settings back to the way they were originally?
    The only way to do it for sure is to restore from a backup made from before you started having a problem since you don't know exactly what you did to create the problem.

    You can try to change the firewall setting, but do make a backup now, including third party apps before trying it:

    http://forums.crackberry.com/f3/upda...updated-53201/
    08-08-09 06:29 PM
  8. red33's Avatar
    the only problem with that is, i have a mac. my mac doesnt support the BBDM yet. at least not until sept
    08-08-09 06:36 PM
  9. xliderider's Avatar
    Ouch, do you have a friend or relative you can borrow some computer time on? At least you can make a backup and save the file on your memory card for emergency use (need a PC, but at least you have the backup file).

    Otherwise, you are really operating without a safety net.
    08-08-09 06:41 PM
  10. markm's Avatar
    My guess is that you inadvertently told the firewall to deny gmail permission to access a site and told it to not ask you again. I'm not certain how to undo that. As a temporary workaround, you could turnoff the firewall which then has the unfortunate habit of having every third party app asking if they can connect. Alternatively, you can try installing the gmail app again. I think the firewall may ask again if it detects the software has changed.

    Good luck

    Rgds/Mark M.
    08-08-09 11:04 PM
  11. markm's Avatar
    Or, you could try the following (which I just found) to reset the firewall for gmail:

    1) Go to options
    2) Advanced options
    3) Applications
    4) Scroll down to GMail and click the BB button to bring up the menu
    5) Select Edit Permissions
    6) Click the BB button to bring up the menu
    7) Select the "Reset Firewall Prompts" menu item
    8) Escape until you are back on your home screen and try GMail again

    Hope that helps


    Rgds/Mark M.
    08-08-09 11:10 PM
LINK TO POST COPIED TO CLIPBOARD