1. seanboyle's Avatar
    I bought an unlocked BB 8900 in the states prior to my departure to China. I now have a China Mobile SIM installed.

    I can call landlines no problem. I can receive cell calls and send SMS without any problems. But I can not call other cell phones. I get a message telling me that I need to subscribe to "IDD" (International Direct Dialing??). I can take the sim card out and put it in another cell phone and it works just fine.

    What setting could create this issue? This never happened in the states.

    Thanks,

    sean
    07-11-09 10:07 PM
  2. seanboyle's Avatar
    Blackberry has a feature called smart dialing. What this does is when you are in a foreign country, recognize a foreign number and attempt to put the home country's calling code prior to dialing even though you have the foreign country's SIM card, such as China Mobile.

    Under phone menu, scroll to option, to smart dialing, then ensure that you have the correct country's calling code in place. This will remove the phone's pursuit of international dialing and recognize the correct numbers.

    In this case, since I have a China Mobile SIM card, I changed the country calling code from 01 (US) to 86 (China) and my problems went away. (This is all in thanks to my IT manager who by now is very tired of solving blackberry issues from America)
    Last edited by seanboyle; 07-13-09 at 08:23 AM. Reason: enhancement
    07-13-09 08:20 AM
  3. lazerus's Avatar
    Interesting, thanks for the tip!
    07-13-09 09:01 AM
  4. aristile's Avatar
    Ah Smart Dialing ... not so smart after all!!

    Glad you got it figured out.
    07-13-09 01:15 PM
  5. FrancoRey's Avatar
    Sorry to bring this thread back from the dead, but I am having the same exact problem Seanboyle had. I have a Blackberry Pearl 8110 and obviously I also found out about smart dialing. However, I have an even BIGGER problem. When I go into my options, I do not have a smart dialing tab! I don't know if it was deleted or it never existed, but it is very frustrating to know how to fix a problem and not be able to do it. Does anyone know why this tab is not here? I even found out about this smart dialing just by going into my phone's 'help' section, where it tells me exactly how to do it. But now, the 'smart dial' file isn't even there! So frustrating!

    Does anyone know how I might be able to get the country code changed in some other file or way? I don't know why my phone's help section would lead me to a part of the phone that doesn't even exist! Thanks.
    Last edited by FrancoRey; 08-05-09 at 11:38 PM.
    08-05-09 11:35 PM
  6. aristile's Avatar
    Phone (Green) button > BB Button > Options > Smart Dialing > Country Code (First Option)
    08-05-09 11:43 PM
  7. FrancoRey's Avatar
    You sir, ARE truly the Crackberry Genius of Geniuses!

    Much thanks. I very much appreciate the extra info.
    Last edited by FrancoRey; 08-05-09 at 11:58 PM.
    08-05-09 11:54 PM
  8. aristile's Avatar
    I just get lucky when I drink!


    P.S. I really do appreciate it!
    08-05-09 11:56 PM
LINK TO POST COPIED TO CLIPBOARD