1. jennycraig's Avatar
    I tried using my Blackberry Curve today to open messages received during the night. Everytime I push the rollerball, it just displays the # sign (or the letter Q). It isn't stuck on anything--I can roll it to any application--but when I push it, all I get is the # sign. I can't open any application. Any ideas? Thanks!
    08-15-09 10:00 AM
  2. lastraid's Avatar
    With the device powered, pull the battery for 15 seconds then put it back in. See if this helps
    08-15-09 10:15 AM
  3. gsoscott's Avatar
    Until you fix the trackball just use the enter key (it's the 2nd from the bottom rightmost key) to select or open apps or messages. Could try removing the bezel and popping out the trackball, clean it out. Might not help but enter key will give you a work around til fixed.
    08-15-09 10:20 AM
  4. The Consigliere's Avatar
    I just had a problem with my trackball, I couldn't scroll left or right, I know it's not the same one that you're having but here's what I did. I simply took my TB out & rubbed between my fingers pretty hard for about 20-30 seconds, it may sound odd, but it worked & now my TB is back to normal & works like a charm.
    08-15-09 04:19 PM
  5. islandgal808's Avatar
    Sorry for jumping in here, but my trackball works fine going left and right, up and down but it doesnt let me open icons
    08-15-09 05:11 PM
  6. anon(2051033)'s Avatar
    Hmmm seems alot of people are having this problem, I think there is another thread for someone with the same problem. Not sure what the fix is if there is one.

    @islandgal808: did you try a battery pull?
    08-15-09 06:02 PM
LINK TO POST COPIED TO CLIPBOARD