08-28-09 08:45 AM
51 123
tools
  1. mattred's Avatar
    I work in a Sprint indirect dealer, I have a Curve along with the two other people I work with. We've all had issues just in the past week or two alone with serious battery drainage. I used to be able to charge my phone every other night and get away with it; last night I charged the phone and it was on red by 3:00 with very low usage. The other guys I work with have also noticed the same thing just in the last couple weeks, especially the last 5 days or so.

    The kicker is that I've had at least 10-20 customers in the past week complaining about the same thing, when usually these complaints are few and far between.

    I even put a brand new battery in my device and have been having the same issues. We also all got our phones at different times; I got mine in February.

    Maybe some sort of update went out that is killing the battery? Has anyone else noticed this issue?
    07-01-09 06:44 PM
  2. Weens's Avatar
    Same problem. I went and bought another battery and don't pay too much attention anymore, but I'm gonna throw the blame at Facebook 1.6. Its the only thing I've really changed.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-01-09 06:46 PM
  3. Kevin8503's Avatar
    Yes

    Posted from my CrackBerry at wapforums.crackberry.com

    Posted from my CrackBerry at wapforums.crackberry.com
    07-01-09 06:46 PM
  4. mattred's Avatar
    Same problem. I went and bought another battery and don't pay too much attention anymore, but I'm gonna throw the blame at Facebook 1.6. Its the only thing I've really changed.

    Posted from my CrackBerry at wapforums.crackberry.com
    Thats my only theory at this point as well, but I just updated facebook in the last couple days and this seems like it has been going on a little longer than that. Plus the other guy I work with doesn't even have FB on his Curve.

    And to avoid all the obvious questions, we've already checked all the bg apps, bluetooth, and all that good stuff; it's a bigger issue than that.
    07-01-09 06:50 PM
  5. Weens's Avatar
    Weird that the other guy without FB has the same issue. That would make me think some sort of carrier push, but we're all on different carriers. I'm clueless, and I don't like it haha!

    Posted from my CrackBerry at wapforums.crackberry.com
    07-01-09 06:52 PM
  6. exelant's Avatar
    Do you notice if your device is searching for a signal? Aside from Facebook, a known battery drainer, searching can use up a battery.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-01-09 06:53 PM
  7. bacon.jay's Avatar
    Last poster has a good point. maybe you should update your roaming? I know that sometimes with my dumbphone even that if i get into battery issues and then i update my roaming capabilities that it doesn't have to work as hard to get a signal and it fixes it. with verizon it's *228 i believe, not sure what it would be with sprint...
    07-01-09 07:31 PM
  8. exelant's Avatar
    You can also try to register, don't know if it'll help, but it can't hurt,
    Register Device: Click options> click advanced options> roll down and click host routing table> press your menu key> select register now> click back and close.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-01-09 07:44 PM
  9. drtwrk127's Avatar
    Also noticed same thing in past week- very strange, I don't have FB either- battery used to last at least a full day, but now, it rarely makes it to 4 pm. Maybe something that should be brought up to RIM?

    Posted from my CrackBerry at wapforums.crackberry.com
    07-01-09 07:46 PM
  10. Trishka's Avatar
    I have too. I thought it was because of my Ubertwitter usuage, but I guess not? I have Facebook too but I don't run it as much. It's usually close to dead by 4PM. Even if I'm not constantly on it.
    07-01-09 07:51 PM
  11. losino's Avatar
    Idk. I got a 8330 and u havnt noticed any battery drainage issue
    07-01-09 08:06 PM
  12. p4tr1ck's Avatar
    Yeah I was just about to get on here and ask for some help. I've only had my BB for 3 days now. I was expecting to get at least two days of moderate use out of it. That hasn't happened, I even made sure there were no apps running in the background. Went through and made sure I closed all of them. Do you think Sprint would have any answers yet?
    Last edited by p4tr1ck; 07-02-09 at 09:22 AM.
    07-02-09 09:11 AM
  13. RobNyc's Avatar
    Likewise here ..
    07-02-09 05:15 PM
  14. Gold2Brown's Avatar
    Yes I've noticed the same thing as well...actually I just posted on this very issue earlier today. I don't have Facebook, and I usually can go a day and a half to 2 days without a recharge and yesterday it was on red before I made it home at 5 oclock. Strange...
    07-02-09 06:08 PM
  15. Weens's Avatar
    So if this seems to be happening on a couple different carriers, different countries even, different OS's, with and without Facebook, where does that leave us? The only common ground here is all Curve and RIM. RIM couldn't have pushed anything without somebody noticing, could they?

    Posted from my CrackBerry at wapforums.crackberry.com
    07-02-09 08:36 PM
  16. tomwp's Avatar
    My curve 8330 also seems to drain really fast, I have only had it for about a week. I always make sure everything is closed.
    I am going to try the extended battery and see if that is any better.
    07-03-09 05:40 PM
  17. Shonrisse's Avatar
    I had the same issue for a day. I have a 8320. Went to bed and my phone was fully charged. Woke up the next morning and it's SUPER low. And I don't even have a data plan so it couldn't have been a FB app for me. I pulled the battery and it worked normally afterwards. *shrug*
    07-03-09 06:20 PM
  18. futureboy111's Avatar
    I've had my Verizon 8330 since December 2008, and there haven't been any battery drain issues. The battery only lasts 1 to 1.5 days max, though, but it hasn't gotten worse. My 8700g battery lasted 2-4 days, but the browser wasn't nearly as fast.
    Last edited by futureboy111; 07-03-09 at 07:11 PM.
    07-03-09 07:09 PM
  19. facetious5290's Avatar
    I work in a Sprint indirect dealer, I have a Curve along with the two other people I work with. We've all had issues just in the past week or two alone with serious battery drainage. I used to be able to charge my phone every other night and get away with it; last night I charged the phone and it was on red by 3:00 with very low usage. The other guys I work with have also noticed the same thing just in the last couple weeks, especially the last 5 days or so.

    The kicker is that I've had at least 10-20 customers in the past week complaining about the same thing, when usually these complaints are few and far between.

    I even put a brand new battery in my device and have been having the same issues. We also all got our phones at different times; I got mine in February.

    Maybe some sort of update went out that is killing the battery? Has anyone else noticed this issue?
    Omg! Yes- I have a sprint blackberry curve and have noticed the same thing just in the last few days!!! Battery hardly lasts at all and I got the phone less than 4 months ago!!

    Posted from my CrackBerry at wapforums.crackberry.com
    07-03-09 07:37 PM
  20. chefette's Avatar
    Mattred....I have the same phone you do. Same problems for about a week now. I'm so glad it's not just me. I was beginning to think I had done something to the phone. Thanks for sharing, it made me feel better.
    07-07-09 07:22 PM
  21. M4HL3R's Avatar
    i got my curve a few weeks ago, and havnt noticed any battery issues unless im calling someone, at which time it will go down like its leaking. lol i dont do anything on my phone other than heavy text and bbm, and light browsing.
    07-07-09 07:37 PM
  22. pinball40's Avatar
    i have had the same issues with my verizon phone too... sometimes i cant even make it to 5pm without needing it to charge
    07-07-09 11:03 PM
  23. jlevi's Avatar
    Well... you're not the only ones. I have a Bold 9000 on AT&T. This is my 2nd bold (The first one had no problems)... battery life is baaaaddddd......
    07-28-09 01:43 AM
  24. bainsstatic's Avatar
    I have noticed the SAME!
    I have NO BIS/BES, just Sprint Vision
    No Facebook, Twitter
    07-28-09 02:14 AM
  25. taetae1669's Avatar
    i bought my 8900 when it first came out.... i dont use face book so i took it off my phone and it was doing great.... i am noticing that the battery drains a lot faster now that i have been using my phone for a while. ive been using my 8120 pearl a lot because that battery life is a lot better.... any advice on what you think that it might be
    07-28-09 02:23 AM
51 123
LINK TO POST COPIED TO CLIPBOARD