1. critguy's Avatar
    hello,

    new guy here. love the site.

    i've had my 8330 for 6 weeks. i had to do a battery pull tonight, as no sent emails were getting out.

    it rebooted fine, but there's now a horizontal white line across the entire screen. i've tried 5 battery pulls, but nothing is getting rid of this display glitch.

    anyone got a suggestion?

    Thanks
    03-07-09 12:04 AM
  2. Tremortality's Avatar
    Is the phone working okay otherwise?

    I would try changing the theme to see if that helps - probably wont but it wont hurt to try. If no resolve it might need to be replaced (or the LCD) but hopefully an actual guru will read this with better advice

    I am not sure if this could be software or hardware but more than likely a hardware failure - Best of luck
    03-07-09 12:09 AM
  3. dingyh's Avatar
    wow,I would like to get an 8330
    03-07-09 12:37 AM
  4. savioAMG's Avatar
    I think Tremortality is correct. Did you bump the phone or drop it? Even on a soft surface, or a small drop onto a bed from around a foot or something similar? The video cables (?) could've been already lose and then the "impact" made it worse. Just my guess.
    03-07-09 12:39 AM
  5. xliderider's Avatar
    Just to be sure, when you do a battery pull, the BB is on correct? If you are turning the phone off before removing the battery, then you aren't doing a proper battery pull.
    03-07-09 02:00 AM
  6. critguy's Avatar
    hi,

    thanks for the replies.

    yes - phone is working fine otherwise.
    nope - not dropped or bumped
    yes - battery pull was done with the power on
    yep - tried changing theme

    gotta be a hardware failure. i'm taking it in today. a little annoying when it's only 6 weeks old. plus the track ball sticks sometimes.

    other than that, it's the best phone like evaaaaar!
    03-07-09 07:13 AM
LINK TO POST COPIED TO CLIPBOARD