1. mikebasilico's Avatar
    I'm having a bizarre issue with my Blackberry buttons.
    My trackball presses "*#"
    And several buttons on my keyboard press random letters.
    I replaced the trackball, and cleaned under the keyboard.

    But the problem only starts when its in my pocket, then wears of in 15 minutes.
    I reset the software and updated everything.

    Anyone have a idea or experiencing the same thing?
    06-23-10 02:53 PM
  2. docsmody's Avatar
    Try doing a wipe and OS reload if it persists.
    06-23-10 04:26 PM
  3. mikebasilico's Avatar
    But doesnt it seem like hardware if it only does it in my pocket?
    06-23-10 05:13 PM
  4. Motorcycle Mama's Avatar
    Sounds like moisture damage.

    Are you carrying the device in your pocket without a case? Sweating??

    That's not a "glitch". That's user damage to the keypad contacts from moisture.
    06-23-10 08:01 PM
  5. mikebasilico's Avatar
    Yes silicon case, not sweating, and the wettest its been is a quick wipe down with a damp cloth
    06-24-10 12:38 AM
  6. Deathcommand's Avatar
    I have had that
    Batt pull fixed it...

    Posted from my CrackBerry at wapforums.crackberry.com
    06-24-10 12:52 AM
  7. Motorcycle Mama's Avatar
    A "silicon" case doesn't protect the keypad. A damp cloth isn't a good idea.

    The Curve 83xx series is VERY susceptible to moisture damage from high humidity environments.
    06-24-10 07:18 AM
  8. SynisterEvil's Avatar
    I had this problem also. It only happened when I carried the phone in my pocket. (Not a sweat issue as it would happen even when I was indoors with AC on) I assume from being in my pocket and bending the buttons would become jammed or frozen from being pressed during movement. I have since then been using a belt case and have not had any problems. Hope this helps you.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-24-10 08:27 AM
  9. jayfiz's Avatar
    I am having the same problem. When I click the trackball it dials *# then if I try to delete it, it dials 14. I took it to the sprint store and of course it starts working everytime. They said they would give me a replacement but every time I go in it won't do it and they need to actually see it doing it.

    Posted from my CrackBerry at wapforums.crackberry.com
    06-24-10 01:24 PM
LINK TO POST COPIED TO CLIPBOARD