1. zerocontrast's Avatar
    I've got a Curve 8320 that I've had since January (had an 8310) before that. Sine I've had it I've been connecting to my computer via USB with no issues, but today I started having problems. I went to transfer some files onto the memory card and when I plugged it in the battery briefly shows that the phone is charging, but that goes away and I also never get a prompt to use mass storage mode. I tried two different cables on the same computer in two different ports, tried it on another computer and even tried booting the phone up with no memory card. Any ideas what could have happened?

    All of my memory card settings are unchanged as well.
    08-15-09 07:37 PM
  2. xliderider's Avatar
    Sounds like your usb port is a goner, the soldered contacts at the motherboard might've cracked, got loose. Does the usb port on the BB have some wiggle/play on it?
    08-15-09 07:40 PM
  3. zerocontrast's Avatar
    Has a tiny bit of wiggle room, as much as it has always had, but it still charges on a regular charger, just not connected to a PC.
    08-15-09 07:49 PM
  4. xliderider's Avatar
    Check the tiny gold contacts in the usb port for any bent pins.
    08-15-09 07:51 PM
  5. Laura Knotek's Avatar
    Does the USB port work if you insert a flash drive?

    Another possibility is that the USB is turning off to conserve power.

    Go to Control Panel>System and Maintenance>Device Manager>Universal Serial Bus controllers>USB Root Hub and double click. Then click Power Management. Make sure that allow the computer to turn this device off to save power is not checked.
    08-15-09 08:05 PM
  6. zerocontrast's Avatar
    the middle one was lifted up a bit, i was able to push it back in place pretty well with a staple, but it still isn't laying quite flat. would it be a lot of trouble to disect the phone to try to fix it better? or do you know of any good trick to get it fixed better?
    08-15-09 08:19 PM
  7. Dubbin1's Avatar
    Had a bent pin in mine with the same problems you're having, I had to get the phone replaced.

    Posted from my CrackBerry at wapforums.crackberry.com
    08-16-09 12:07 AM
LINK TO POST COPIED TO CLIPBOARD