1. Giorgio89's Avatar
    Hi,

    I am trying to update my device software version from 4.2.2.181 to 4.5.x.xxx. I am updating for the first time and the main reason is that I deleted my BBM and I can only install the new one if my software version is 4.5 or higher.
    Back to the issue. I can see in my device manager that my version is as previously stated but when I try to update it, I get a message saying that there are currently no updates. I also tried downloading the handheld software update (the at&t 4.5.x.xxx version) and that didn't work either. I have a feeling this is somehow connected to the fact that I can't see any other applications than Facebook and another app I installed in my desktop software (i see no BBM, and never did, no system software, nothing else).
    Anybody has any ideas?

    Thanks in advance

    J
    08-30-10 02:51 PM
  2. jeffh's Avatar
    If you don't see your system software, then you don't have your OS installed on your PC. Double-click the 4.5.x.xxx OS file you downloaded. That will install it as an app on your PC. Then run the app loader and it will see the upgrade files.
    08-30-10 03:02 PM
  3. Giorgio89's Avatar
    I can see the system software at the home screen of desktop software. Only when I click applications tab, can I only see Facebook and nothing else. As far as the installation goes, I installed the 90mb (cca) package and nothing changed. I even uninstalled the desktop manager and installed the completely new version with no positive result. I am completely out of ideas
    08-30-10 03:12 PM
  4. jeffh's Avatar
    You didn't address what I told you to do. Did you double-click the OS exe and install it on your PC? If you go to the Windows Control Panel, Add / Remove Programs, do you see the OS listed as an app? Is your BlackBerry an AT&T device?
    08-30-10 03:37 PM
  5. Giorgio89's Avatar
    Oh, sorry about that. Yes the OS exe file is installed and visible as an APP in the control panel. My carrier is not AT&T and I purchased the device here in europe.
    08-30-10 03:56 PM
  6. jeffh's Avatar
    ... My carrier is not AT&T and I purchased the device here in europe.
    Sorry here also, I realize my post sounded short. Since you're trying to install an alien OS, your problem is most likely a copy of vendor.xml somewhere. Even if you deleted it earlier, it may have been put back when you reinstalled Desktop Manager. Use the Windows search tool to find and delete all copies of it. Then don't bother using DM, just go directly to the App Loader and run it. You can find it in C:\Windows\Program Files\Common Files\Research in Motion\AppLoader\loader.exe
    08-30-10 04:01 PM
  7. Giorgio89's Avatar
    Thank you Jeff, that seemed to have done the trick, updating right now. Ill let you know if everything works as it should.

    J
    08-31-10 09:22 AM
LINK TO POST COPIED TO CLIPBOARD