1. Yves's Avatar
    I normally don't like to ask for help until I have no other option but I can't figure this one out myself.

    So here's the scenerio:

    The past two days I've been playing around with Plazmic Theme Builder using the Zen template to make a theme for my 8900. I tried exporting my theme earlier today but everytime I try to download it with my Blackberry I get a "Download Failed" "907 Invalid COD"

    After much googling I saw a number of possible solutions:

    Add the MIME support for JAD and COD through my web host:
    Check, did that. Still no luck

    Make sure parent cod or sibling cod files are not over 54kb
    Check, exported a blank zen template (22kb) and tried to download. Still no luck. Same Error.

    Make sure not to download over wap
    Check, tried over wifi and internet browser. Same Error.

    I don't understand why my theme and the blank template which is an identical copy of the theme that comes with the phone wont download via .jad.

    Is there something I'm missing? Please help.


    *Note: I've already tried changing small things in my theme and rexporting and already cleared my cache numerous times and waited to make sure uploaded files were refreshed on my server

    Here's a quick look at the theme:

    07-20-09 09:25 PM
  2. c_is_for_crackberry's Avatar
    try this...in plazmic export as a axl file then when you go to desktop manager app loader and add app click browse then find where you exported the file to then click it and hit next and it will install
    07-20-09 09:45 PM
  3. Yves's Avatar
    I don't really have an issue installing the theme over desktop manager. What I'm trying to figure out is to get my OTA working
    07-20-09 09:58 PM
  4. c_is_for_crackberry's Avatar
    oh ok well im assuming you have a server or a host, then just make sure you copy the jad and cod files to your server in 1 folder and the ota is just a link to the jad file
    07-20-09 10:04 PM
  5. Yves's Avatar
    Tried that. It's not working. I get 907 COD error
    07-21-09 08:53 PM
  6. mrtolles's Avatar
    Do you have your .htaccess file in the same folder as the theme? Some servers require this, some do not.
    07-21-09 09:51 PM
  7. autonami's Avatar
    the .htaccess file and all your jad and cod files must be uploaded in Binary transfer mode.

    i found when i tried entering the url directly in my browser, i would get the same error

    so i made a short .html file like follows

    <html>
    <body>
    <a href="http://yoursite.com/ota.jad">click for ota</a>
    </body>
    </html>

    when i went to that .hml page in my bb browser and clicked the hyperlink, it worked.

    hope this helped
    Last edited by autonami; 07-22-09 at 12:04 AM.
    07-21-09 11:58 PM
LINK TO POST COPIED TO CLIPBOARD