1. bully74uk's Avatar
    Hi
    Replaced my faulty Curve 8900 today and have just got it home to charge it.
    Im using the battery from my old one.

    On the first Curve, when I charged it the LED was flashing Yellow and then green when fully charged.

    The replacement handset is not flashing at all ? there was a lightening bolt across the battery and it has charged up (on charge for 2 hours) but no LEDs

    I know that the red LED is working because Ive had a couple of texts etc come through.

    Any ideas if this is normal and how I can check if the green and yellow LED are working ?

    Im stumped as to why the charging indicators are different on the two Curves ?

    Will check now if the versions are the same.
    03-06-09 02:21 PM
  2. howejustin's Avatar
    Hi
    Replaced my faulty Curve 8900 today and have just got it home to charge it.
    Im using the battery from my old one.

    On the first Curve, when I charged it the LED was flashing Yellow and then green when fully charged.

    The replacement handset is not flashing at all ? there was a lightening bolt across the battery and it has charged up (on charge for 2 hours) but no LEDs

    I know that the red LED is working because Ive had a couple of texts etc come through.

    Any ideas if this is normal and how I can check if the green and yellow LED are working ?

    Im stumped as to why the charging indicators are different on the two Curves ?

    Will check now if the versions are the same.
    Yellow and green? never seen this...mine stays lit on red while charging.
    03-06-09 02:23 PM
  3. davidnyc's Avatar
    That charging light only happens if you try to charge your BlackBerry while it is completely turned off.
    03-06-09 02:41 PM
  4. fatboy97's Avatar
    That charging light only happens if you try to charge your BlackBerry while it is completely turned off.
    Sounds right to me.
    03-06-09 02:47 PM
  5. ClintRo's Avatar
    Yeah... i never get and LEDs while charging!!
    03-06-09 03:35 PM
  6. bully74uk's Avatar
    That charging light only happens if you try to charge your BlackBerry while it is completely turned off.
    Ah, OK thank you for clearing that up. I did indeed have the first handset fully turned off as it was the first charge with a new battery.

    Yellow and green? never seen this...mine stays lit on red while charging.
    Does anyone else get a red (or any colour for that matter) LED when charging because the replacement handset has NONE. It is running version 101

    one more question about the LED's. When set to "normal" profile and I get a missed call I also have NO LED that flashes after the call is missed. I get a red LED when an email or text comes through but nothing for a missed call. In the profile settings for phone "repeat notification" is set to "LED Flashing"
    Doesn't this mean I should be seeing an LED for a missed call ????


    Thanks in advance for any help.
    03-06-09 03:41 PM
LINK TO POST COPIED TO CLIPBOARD