12-26-12 04:16 PM
28 12
tools
  1. Pmpj172's Avatar
    java.lang.illegalargumentexception everytime i try to open my browser this comes up and it freezes my phone.tried a battery pull ...did nothing any help?
    03-30-10 05:59 PM
  2. dictoresno's Avatar
    did you recently install a new app? looks like it may somehow be in conflict with a browser file.
    03-30-10 06:43 PM
  3. Pmpj172's Avatar
    possibly the problem ill hafta check
    03-30-10 10:24 PM
  4. dictoresno's Avatar
    most likely the problem. start backtracking recently installed apps and see when deleting it, makes the error go away. couldve been a bad install.
    03-30-10 11:57 PM
  5. Pmpj172's Avatar
    deleted all the apps installed still same thing. it was working then this started to happen
    03-31-10 07:19 AM
  6. dictoresno's Avatar
    backup and reinstall the OS then.
    03-31-10 08:03 AM
  7. jmeisenberg#CB's Avatar
    I'm having the same exact issue with my Tour, back it up, reinstalled the OS and still having the issue.
    04-02-10 11:22 PM
  8. sabisogno's Avatar
    I installed OS 5.O on april 1st now when i try to use BB browser I get the same error code and BB is locked. pull the battrery to clear. i can use google and other internet apps. help
    04-03-10 11:10 AM
  9. prosumer12's Avatar
    Getting the same error code when trying to open up the browser directly. Happened April 2nd right after upgrading to new OS 5.0 for Tour 9630. Tried going back to 4.7, then upgrading again... still happens. Frustrating.
    04-04-10 04:32 PM
  10. wards's Avatar
    I had the same issue going on with mine, havnt upgraded to the newest 5.0 OS yet, have .461 right now. Only thing I did was change my start page in browser settings to something other than "start page" and browser pulls up fine. Weird though, havnt had any problems for at least 2 months and all of a sudden.....this "illegal argument" crap! I have the newest OS installed on my pc, just havnt sat down and done it as of yet.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-06-10 09:42 PM
  11. cassith's Avatar
    I got the same error when I upgraded. All I did was open the internet through a page I already had saved outside of the explorer(boxlike.com icon). Then go to my browser settings and set the home page to google.com. It works now and I don't get the annoying freeze-up.
    04-11-10 09:20 PM
  12. superstarme's Avatar
    When I upgraded OS's I had the same error message when attempting to open my browser. Unfortunately, something became corrupt while upgrading. The best way to correct a java.lang error is to reload your OS using App Loader. Then using an older back up from DM to restore your device of personal data(Memos, address book, etc...). If you use the most recent backup, your just putting the corrupt files back in your berry. Hope that helps anyone having the issues.

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by lourdes; 04-12-10 at 05:40 AM.
    04-12-10 05:36 AM
  13. rufaro's Avatar
    Ok. Stupid question from noobie time. What's/where's app loader?

    Posted from my CrackBerry at wapforums.crackberry.com
    04-12-10 10:07 PM
  14. superstarme's Avatar
    Ok. Stupid question from noobie time. What's/where's app loader?

    Posted from my CrackBerry at wapforums.crackberry.com
    On your PC/laptop Go My Computer>Local Disk C>Program Files>Common Files>Research In Motion Folder>App loader. Be sure to delete the vendor.xml file if its not your carrier.
    04-15-10 02:25 AM
  15. sjhiam's Avatar
    I just upgraded to 5.0.0.591 last night then got this error trying to open my browser. I changed the theme back to one of the default themes that came with the phone, and I no longer get the error. Must be related to the theme - which I PAID for and now can't use!
    DollarVoter likes this.
    04-18-10 03:21 PM
  16. KeNNethX's Avatar
    I just upgraded to 5.0.0.591 last night then got this error trying to open my browser. I changed the theme back to one of the default themes that came with the phone, and I no longer get the error. Must be related to the theme - which I PAID for and now can't use!
    I am having the same problem...I don't have the error on the built-in themes...I have it on any 3rd party theme.
    04-27-10 08:23 AM
  17. wards's Avatar
    Crap!!! I hope it isn't the "3rd party Themes" causing the probs! I am very attached to my current one!

    Posted from my CrackBerry at wapforums.crackberry.com
    04-29-10 12:44 AM
  18. kristian g's Avatar
    im having a problem i cant get any sms messages it keeps saying java.lang.NullPointer expections
    04-29-10 07:02 PM
  19. tnmurdock's Avatar
    I have only gotten the error when trying to access my browser in two themes... the ninja theme(just purchased and whoah is is it awesome) and the soke free theme was on crackberry the other day. ONLY get the error with either two of these themes. No others. However, I think I have ruined tech supports night for the ninja. But they are on it. MAN, I hope I can keep the theme...it rocks!
    05-14-10 10:06 PM
  20. Flatfoot75's Avatar
    I have only gotten the error when trying to access my browser in two themes... the ninja theme(just purchased and whoah is is it awesome) and the soke free theme was on crackberry the other day. ONLY get the error with either two of these themes. No others. However, I think I have ruined tech supports night for the ninja. But they are on it. MAN, I hope I can keep the theme...it rocks!
    Any update for these themes. I have the ninja blackout theme and can no longer use my browser because of it. I s'pose the easy way would be to get rid of the theme but it is great (and I paid for it). Are they still working on it does anyone know?
    05-24-10 12:23 PM
  21. not_addicted77's Avatar
    I changed the theme back to one of the default themes that came with the phone, and I no longer get the error. Must be related to the theme - which I PAID for and now can't use!
    This worked for me also. I went back to the default and the browser is working, but my themes are free so actually I don't mind the default, I changed thru them anyways. But glad the error is done. As long as apps don't create this error, that's the main thing I think. I have the tour on VZ.

    Posted from my CrackBerry at wapforums.crackberry.com
    Last edited by not_addicted77; 06-30-10 at 10:06 AM.
    06-30-10 10:04 AM
  22. luvmyhubby's Avatar
    I had the same issue going on with mine, havnt upgraded to the newest 5.0 OS yet, have .461 right now. Only thing I did was change my start page in browser settings to something other than "start page" and browser pulls up fine. Weird though, havnt had any problems for at least 2 months and all of a sudden.....this "illegal argument" crap! I have the newest OS installed on my pc, just havnt sat down and done it as of yet.

    Posted from my CrackBerry at wapforums.crackberry.com
    I was getting the same thing with different themes I tried to use. I did exactly what I quoted on this post. It worked for me. So please try it. I have no idea why worked. It does seem a heck of a lot easier than deleting OS's and reloading them. What a pain. Hope this keeps working!
    Thank you!
    06-30-10 03:26 PM
  23. rgarling's Avatar
    A theme should not cause the error that you are seeing. As a themer we only change the "skin" of the browser icon. We cannot change it's functionality.
    07-21-10 06:22 AM
  24. aNYthing24's Avatar
    A theme should not cause the error that you are seeing. As a themer we only change the "skin" of the browser icon. We cannot change it's functionality.
    Well, this JUST happened to me and I changed the theme to the original one and bam - it's working again.
    07-22-10 07:06 AM
  25. PrettyTony80's Avatar
    I just solved my problem, it was the theme I was using. Had to change it.
    09-15-10 02:24 PM
28 12
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.