1. rootbeersoup's Avatar
    So whenever I'm home, it automatically connects to my wifi with no problem, and it ALWAYS shows UMA when I'm home. However, I am noticing that while I'm on a call, it drops and switches to GPRS or EDGE. Why does it do this? It never drops to GPRS or EDGE when I'm not on a call, but for some reason when I make a call, it drops. Is there something wrong with my settings? This is incredibly annoying as this is the main purpose I got a BB for, since I'm on T-Mo and I don't get good coverage at my house.
    03-06-09 02:49 AM
  2. dolphinguy's Avatar
    under options in the manage network are you set on wifi preferred?
    03-06-09 03:27 AM
  3. rootbeersoup's Avatar
    Yeah I've always had it on wifi preferred... Like I said,this only happens while on a call

    Posted from my CrackBerry at wapforums.crackberry.com
    03-06-09 04:11 AM
  4. stansz's Avatar
    perhaps it is ur router? i know i had to upgrade my routers firmware and reset the router for my uma to work properly
    03-06-09 04:17 AM
  5. rootbeersoup's Avatar
    Would the router make it fail on calls only? UMA does pop up briefly while I'm in a call. But it's mostly GPRS or EDGE. And it always says it's on UMA when it's not on a call when I'm home. It's never once dropped unless it's during a call.
    03-06-09 05:23 AM
  6. flash24's Avatar
    Get an extender for your router. Also, upgrade your router's firmware. This happens to me when I'm not close to my router, so I decided to get an extender and it solved my issue.

    Or

    You can always get a better router with greater coverage. Good luck.

    Oh and I'm using the TMO Linksys router, it's coverage isn't that great.
    03-06-09 06:23 AM
  7. rootbeersoup's Avatar
    I'm like 50 feet away from the router... I always have 3 bars of UMA and I'm still connected to wifi while pulling out of my driveway. I don't think coverage is the issue. I don't have T-Mo router either, but it is a Linksys router
    03-06-09 06:47 AM
  8. evrydayzawrkday's Avatar
    This happens when the secure tunnel the phone makes with the wifi router is broken (aka you loose wireless signal).

    Try...

    *Upgrading your OS on the BB
    *Upgrading the firmware on your wifi router
    *battery pulls
    *deleting your wifi profile and readding it
    *Making sure wifi is perfered.

    I havent had these issues with the 8900 UMA, but the 8320's UMA.. eventually all of these fixed the issue.

    Note, if you walk outside the range of your wifi connection, that might cause it also.

    So whenever I'm home, it automatically connects to my wifi with no problem, and it ALWAYS shows UMA when I'm home. However, I am noticing that while I'm on a call, it drops and switches to GPRS or EDGE. Why does it do this? It never drops to GPRS or EDGE when I'm not on a call, but for some reason when I make a call, it drops. Is there something wrong with my settings? This is incredibly annoying as this is the main purpose I got a BB for, since I'm on T-Mo and I don't get good coverage at my house.
    03-06-09 08:23 AM
  9. Redbone75's Avatar
    I have also noticed the call im currently on using UMA drops as soon as I get out of range from my router or the call is choppy. I've had the phone for a month and a half now, Im use to it now and so is the person on the other end.. Its does come in handy when I really dont wanna talk to someone, I say my wifi is tripping and that gets me off the phone!! I'm kewl with it, it has its benefits
    03-06-09 08:28 AM
  10. howejustin's Avatar
    Guys, none of you have made mention that this is a KNOWN ISSUE with this phone's OS. The version the OP has displayed in their header, .114, supposedly has the best radio code for UMA calling (I used it in my hybrid install with .152) however it still does drop calls every now and then. If you have 3 bars of UMA service, you're fine. No need to get a universal extender or another router with greater coverage, which by the way, is a wireless N router that will make absolutely no difference with a BB as the BB only recognizes B and G bands. They do have a couple routers (linksys being one of them) that have more antennas inside, but if you're getting 3 bars, you're fine.
    Next, your firmware may play a part in your calls being dropped, but I doubt it. It's OK to eliminate that POF (point of failure) though with an update. Just log into your router and update it's firmware.
    Lastly, I've upgraded to the newest OS .168 which seems to be very stable. I called my home phone last night and left the call active for about 10 minutes, nothing got dropped whatsoever. You may have good luck with .168.
    Last edited by howejustin; 03-06-09 at 09:34 AM.
    03-06-09 09:31 AM
  11. Doctor A's Avatar
    Justin I am glad you spent the time/effort to post this-very informative. I occasionally have disconnects and you answered questions that were dancing in my head. I think it is just nature of the technology and is not 100% reliable all the time.
    Doc
    03-06-09 11:42 AM
  12. aristile's Avatar
    Also check out the WiFi Guide link in my signature for much more great information and troubleshooting.
    03-06-09 11:49 AM
  13. rootbeersoup's Avatar
    Thanks for all the help guys! It turns out that it was probably the blackberry... I just got my 4th 8900 (that's right, I've had it replaced thrice) and this one doesn't drop its UMA connection during a call

    Go figure...
    03-08-09 07:40 AM
  14. apU823's Avatar
    My phone used to drop mr calls wheb I first got the phone on uma but some thing as simple as a hard reset (pull the power) on the router, I'm good to go. Along with my weekly battery pull, I now do a hard reset of my router

    Posted from my CrackBerry at wapforums.crackberry.com
    03-08-09 11:29 AM
  15. JuslisenLX's Avatar
    Don't feel like its your BB. Mine does the same thing, I think its just the PHONE itself. When it does drop UMA and switches to Edge my calls quickly drop because wi-fi is still on. So I have to uncheck wi-fi if I don't want my calls to drop. I never had a call drop problem before.
    03-08-09 11:46 AM
  16. evrydayzawrkday's Avatar
    Ok ...

    *I have had this issue for a while dating back to when I had my 8320 unfortunetly.. fixed it by disabling the firewall on my wifi router, but then leaves my laptop vulnerable, so I could deal with this.

    *The reason you get dropped calls going from UMA/EDGE is because the secure tunnel used to create the call has been broken.... if you go from EDGE to UMA (at least on the 8320) it doesnt break though! Very wierd IMO...

    Don't feel like its your BB. Mine does the same thing, I think its just the PHONE itself. When it does drop UMA and switches to Edge my calls quickly drop because wi-fi is still on. So I have to uncheck wi-fi if I don't want my calls to drop. I never had a call drop problem before.
    03-08-09 09:51 PM
LINK TO POST COPIED TO CLIPBOARD