1. CobaltGirl87#CB's Avatar
    hey all. so i have a small problem. actually, its a huge one. i have the 8900 and the freakin scroll ball wont go down. goes left, right, up but not down (thats what she said, right?) i know i could probably take it out and clean it but

    A) no idea how
    B) will that void my warranty??

    i have already ordered a new replacement one but i cant live without my blackberry that long.

    ideas?
    08-28-09 11:53 AM
  2. berryite's Avatar
    i could probably take it out and clean it but

    A) no idea how
    B) will that void my warranty??

    ideas?
    Spray some Windex into a soft cotton towel and wipe the towel across the trackball in all directions. Give it a few minutes to dry and repeat a couple times more later in the day and see if that improves it.

    If you get the trackball oily or greasy, you can have these types of issues.
    08-28-09 11:59 AM
  3. lazerus's Avatar
    Please do this...this is the easiest fix without chemicals.

    Open an app such as brickbreaker and pess down very hard and move the tball around.

    I say brickbreaker since it won't go dialing or texting exs or other scrub types.

    08-28-09 12:11 PM
  4. Dennysonr's Avatar
    Please do this...this is the easiest fix without chemicals.

    Open an app such as brickbreaker and pess down very hard and move the tball around.

    I say brickbreaker since it won't go dialing or texting exs or other scrub types.

    texting exs..lol
    08-28-09 12:14 PM
  5. johntkong's Avatar
    Please do this...this is the easiest fix without chemicals.

    Open an app such as brickbreaker and pess down very hard and move the tball around.

    I say brickbreaker since it won't go dialing or texting exs or other scrub types.

    "other scrub types" LOL .. that's great!
    08-28-09 12:19 PM
  6. visualpurple's Avatar
    dip a qtip in rubbing alcohol, and smush it all over the trackball. Worked like a charm when my trackball wouldn't scroll horizontally.
    08-28-09 01:35 PM
  7. CobaltGirl87#CB's Avatar
    hahahaa yeah....we dont want my phone doing any calling or texting of exes. thats bad news right there
    08-28-09 02:57 PM
  8. tcamshafter's Avatar
    what i did was what Lazerus suggested but i also took batt out and put some good rubbing alc on a lint free fabric. pushed down hard on the ball and worked it..after about 5 minutes put batt back in and wala......good as new
    08-28-09 08:57 PM
  9. .cw54o's Avatar
    i was having the same issue, i seen a thread on here about 2days ago .&. it said to put a tiny drop of purel hand sanitizer on a napkin, smooth it out .&. wipe the ball in all directions <-- it actually worked .&. it took like 30seconds
    08-29-09 12:15 AM
  10. o0stryxs0o's Avatar
    Also try a search for this issue it usually comes up about once a week and there are a ton of ideas on how to fix it and things so check that out also!

    Posted from my CrackBerry at wapforums.crackberry.com
    08-29-09 05:50 AM
  11. cbwannabe's Avatar
    i was having the same issue, i seen a thread on here about 2days ago .&. it said to put a tiny drop of purel hand sanitizer on a napkin, smooth it out .&. wipe the ball in all directions <-- it actually worked .&. it took like 30seconds
    Sounds like maybe this should be a regular maintenance thing rather than wait until there is a problem?

    BTW, rather than a napkin I'd think a some type of lint free microfiber cloth would be better.

    Also lock the keyboard or put in standby and hold the 8900 face down as you clean the trackball? Also like the Brickbreaker idea though.
    08-30-09 10:51 AM
  12. CobaltGirl87#CB's Avatar
    yeah i got it to work long enough for the weekend, and now its working temporarily off and on. lil worried when i get the new one Tmobile will be all like "its not broken, pay a fine" but theyre pretty good about it usually thanks everyone
    08-31-09 06:26 PM
  13. konabean's Avatar
    Windex and Q-tip saved the day. Thanks.
    09-01-09 10:01 AM
  14. jesslynxatticus's Avatar
    I had this problem with my 8120. Wouldn't go -down- for some stupid reason, every other direction worked perfectly! I did clean it some, but it didn't make a difference. Want to know what worked?

    Losing the silver ring that keeps the trackball in place. LOL. I called Rogers, they were sending me a replacement phone... Lose the ring while waiting, problem solved. Was no need for a new one (which they messed up on, and then now it's "damaged" and they won't give me a replacement, ugh).

    Yeah... I'm thinking that regular maintenance is a good idea, for these more easily-fixed trackball issues!
    09-02-09 04:32 AM
  15. cally69's Avatar
    Put phone in standby mode and press down hard on trackball while moving it all around. Works every time!
    09-02-09 05:03 AM
  16. barkway's Avatar
    I have same issue with track ball scrolling every direction EXCEPT for downward. I tried all the methods suggested here for cleaning it but it still won't scroll down which is a major pain in the arse since that means I can only use the applications on my Home Screen that are in the top row and even then, I can't use any function in those that requires me to scroll DOWN!

    I lost my USB port first a few months ago and got by with the cradle charger but loss all ability to transfer data via USB...now this track ball issue. Man these phones are CRAP!
    11-08-09 05:48 AM
  17. chew_wat's Avatar
    Try using alcohol swaps,works for me so far.A usb cable can be easily brought for,like 5 bucks. My friend got one so she can charge it anywhere n she don't have to bring it around.

    Posted from my CrackBerry at wapforums.crackberry.com
    11-08-09 02:25 PM
  18. alexs0fly's Avatar
    I've had several problems with my trackball. I'm considering switching to a trackpad phone or just getting an iphone
    11-08-09 03:13 PM
  19. skicop's Avatar
    Lint free alcohol based eyeglass wipes work well to clean the trackball.
    04-25-10 02:34 PM
  20. Pete6's Avatar
    If you do all the above and it still won't work then you need a new trackball. This happened to mine and I documented it here http://forums.crackberry.com/f100/st...t-ball-441094/
    04-25-10 02:42 PM
  21. filipinoy973's Avatar
    Take the trackball assembly apart and clean the sensor rods. There are grooves on each rod. Wipe them all clean. I used a q-tip dampened with alcohol. Works just like new.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-25-10 11:08 PM
LINK TO POST COPIED TO CLIPBOARD