1. Artemis68's Avatar
    I got my T-mobile branded 8900 today. I cannot for the life of me get MMS to work, nor UMA.

    The reps I contacted tried everything but to no avail.
    I think there's something in the software, because the message doesn't even TRY to send, it just goes to a red X.

    As for the UMA, I will connect to a strong network (my router is above my bed) and am able to surf with it. If I turn off the mobile network and try to call, the call fails...

    Seriously, what do I do?
    01-22-09 08:50 PM
  2. howejustin's Avatar
    Can you browse the internet while connected to WiFi, with the regular network turned off?
    01-22-09 08:58 PM
  3. Artemis68's Avatar
    Can you browse the internet while connected to WiFi, with the regular network turned off?
    Yes I believe so.

    I hadn't tried a battery pull though. I will do that now.
    01-22-09 09:01 PM
  4. aristile's Avatar
    I thought we were helping you address this problem in this thread already?

    Did you follow the WiFi guide? Did you enable UMA on your account with T-mobile?
    01-22-09 09:01 PM
  5. howejustin's Avatar
    I thought we were helping you address this problem in this thread already?

    Did you follow the WiFi guide? Did you enable UMA on your account with T-mobile?
    The only thing to enable with T-Mobile is unlimited UMA WiFi calling...but that only allows you to use UMA as much as you want without going into your bucket of minutes, it has nothing to do with whether you can use UMA or not. It should automatically go into UMA mode as long as your WiFi signal is strong enough (doesn't need to be very strong either).
    01-22-09 09:29 PM
  6. Artemis68's Avatar
    Wi-Fi was easy to set up and it works well. Battery pull didn't do anything...should I wipe out the phone?

    Posted from my CrackBerry at wapforums.crackberry.com
    01-22-09 09:40 PM
  7. Artemis68's Avatar
    Okay, I've decided I'm going to reset the entire thing. Wipe it out, install OS, and resend service books again.

    Can someone please point me to a guide that will help do this safely so I don't brick my phone?
    01-22-09 09:43 PM
  8. pltaylor's Avatar
    It's not worth all that. It's brand new. tell 'em send you another one.
    01-22-09 09:53 PM
  9. Artemis68's Avatar
    It's not worth all that. It's brand new. tell 'em send you another one.

    I don't know. Will they send me a new one first or do I have to send mine back?
    I freaking HATE my 7290 and don't want to use it EVER again. Ugh. I also don't want to pay for shipping. it's THEIR fault my phone isn't working properly.
    01-22-09 09:58 PM
  10. pltaylor's Avatar
    They will 2 day you one with a return shipping package to send that one back. That's a high end phone. And while wiping and reinstalling etc. may fix it. You shouldn't have to go through that. I wouldn't.
    01-22-09 10:02 PM
  11. Toddboy71's Avatar
    Also goto options/advanced options/service books and make sure your service book for MMS is MMS Config 2.0(WPTCP) . In the past few months, tmo changed the service book for MMS, and it's entirely possible you may have ended up with the old one somehow. Just a guess and something else to try. If it's the old one, just delete the old one, reboot, and resend your service books. Hope you get you baby up and running great!
    01-22-09 10:43 PM
  12. DaPhoneking's Avatar
    I don't know. Will they send me a new one first or do I have to send mine back?
    I freaking HATE my 7290 and don't want to use it EVER again. Ugh. I also don't want to pay for shipping. it's THEIR fault my phone isn't working properly.
    I know... off topic...

    What's wrong with your 7290?
    01-22-09 11:05 PM
  13. aristile's Avatar
    Okay, I've decided I'm going to reset the entire thing. Wipe it out, install OS, and resend service books again.

    Can someone please point me to a guide that will help do this safely so I don't brick my phone?
    Check my signature. I have a guide to the upgrade procedure and also a guide to setup WiFi so UMA works. I think if you follow both of these guides you will get it to work. If you follow the guides correctly and you still have problems then I guess you can return the phone for a replacement.
    01-22-09 11:17 PM
  14. Artemis68's Avatar
    Actually I called and all is well. I ended up talking to some BB gurus there lol. They said there's an mms outage right now in my area, and they set up the 911 info so I can UMA now they were very helpful

    Posted from my CrackBerry at wapforums.crackberry.com
    01-22-09 11:18 PM
  15. aristile's Avatar
    Awesome, so you got this all figured out now and it was all carrier related settings?
    01-22-09 11:36 PM
  16. Artemis68's Avatar
    Yeah nothing wrong with my baby, thank good. And MMS works again YAY

    Posted from my CrackBerry at wapforums.crackberry.com
    01-22-09 11:51 PM
  17. aristile's Avatar
    Sweet, Enjoy it up!
    01-23-09 12:00 AM
LINK TO POST COPIED TO CLIPBOARD