1. daafje's Avatar
    Hi, I recently got my first Blackberry and the only problem i have is with gprs. I just cant seem to turn it off, I have tried to set the Data Services to off but this also blocks my wifi connection. Also I want to know if a webpage is loading with gprs or wifi, is there a way to see this? Im using Opera Mini.

    Thanks
    01-21-09 02:10 PM
  2. Sith_Apprentice's Avatar
    should be able to set WiFi as the preferred network under mobile options. This is usually the default though.
    01-21-09 02:13 PM
  3. daafje's Avatar
    I can only choose from network providers in the "MyPreferred network list" no wifi there. Am i in the wrong menu?
    01-21-09 02:49 PM
  4. Taryon's Avatar
    As Sith_Apprentice mentioned, in the network settings you can leave data services on and choose network preference as "WiFi Preferred". If you want to use WiFi for web-browsing and really ensure no mobile network data is being used, in the Manage Connections box, uncheck mobile network and only check WiFi.
    01-21-09 02:55 PM
  5. aristile's Avatar
    The "WiFi Preferred" option only applies to UMA calling as far as I am aware.

    Go into Manage Connections and then uncheck the "Mobile Network" box, that will turn off the cellular antenna on your phone and thus GPRS.
    01-21-09 03:07 PM
  6. daafje's Avatar
    I'm pretty sure you are talking about a menu you have, but I don't.
    When i go to options -> Mobile network i can only see Data services, Mobile Network and Network selection mode. No such thing as network preference though
    01-21-09 03:12 PM
  7. daafje's Avatar
    But that way i cant recieve any ponecalls, so thats not an option.
    01-21-09 03:15 PM
  8. DD1968's Avatar
    If you go into the setting actually in opera mini while it is open, scroll to thje bottom and check the wifi box. Then pres the menu button and select and click on save. That will allow you to only connect using wifi...

    Posted from my CrackBerry at wapforums.crackberry.com
    01-21-09 03:15 PM
  9. aristile's Avatar
    Also you can try the new Bolt Browser. It is still in beta but I believe it only connects via WiFi.
    01-21-09 03:17 PM
  10. DanGleebitz's Avatar
    Go to Menu > Options > Advanced Options > Browser and then under Default Browser Configuration, choose Hotspot Browser, that'll get you surfing away on WiFi.
    01-21-09 03:22 PM
  11. Taryon's Avatar
    Yeah you're right, aristile. I just read the help pages on it to confirm it's for UMA calling.

    daafje: The only things you can do to "force data over WiFi only" is either ONLY check the WiFi connection box or use the BB Browser and set it to HotSpot/WiFi. I'm also guessing you're not seeing the Connection Preference since you don't have a T-Mo branded 8900 to use their HotSpot (UMA) service.. ?
    Last edited by Taryon; 01-21-09 at 03:52 PM.
    01-21-09 03:23 PM
  12. daafje's Avatar
    Thanks for the reply's, i have Mobile Network turned off now and it reveals that wifi isnt even working in opera mini or gmail. it is however working with the BB Browser. Maybe i can find some awnsers on the forum.

    Taryon: nope, no connection preference
    01-21-09 03:33 PM
  13. Taryon's Avatar
    I haven't had a chance to load up Opera Mini so I can't comment on whether it has a WiFi/HotSpot mode or not. If not, it will only work by using your mobile network for data. Your BB Browser is working because you have it on WiFi/HotSpot mode.

    Also, the Gmail app won't work with WiFi at all.. you need a data plan for that. Cheers.
    01-21-09 03:55 PM
  14. Cautious's Avatar
    The option for "wifi prefered", depends on your network provider. I had an 8900 from Vodafone Uk, who only allow web browsing on wifi, I did not have that option. I changed for an Orange handset and now I have this option.
    01-21-09 04:24 PM
LINK TO POST COPIED TO CLIPBOARD