1. Briandagreat908's Avatar
    I have an unlocked Blackberry Bold and it is not connecting to my T Mobile network. I have put about 5 different T Mobile sim cards in the phone and none have worked. I just keep getting an SOS signal. When I put a AT&T sim card it works perfectly. I called T Mobile and RIM went thru their troubleshooting and it still doesn't work. Does anybody have any solution. I checked the phone and the network displays Disable so I know the phone is still unlocked. How can this happen?? Is this a rare case or did this happen to anybody else who has an unlocked Bold to T Mobile service.
    06-29-09 06:38 PM
  2. Username00089's Avatar
    What OS is the phone running?
    06-29-09 08:35 PM
  3. Scottmog's Avatar
    I know this is a ******** question but, are the cards current? As in are there plans for the cards you are using or are they just random old cards.
    06-29-09 09:07 PM
  4. Briandagreat908's Avatar
    I ran a lot of different OS nd it happens in all of them
    07-06-09 05:38 PM
  5. Willie2Short's Avatar
    Where are you getting all those T-mobile sim cards?
    07-06-09 05:44 PM
  6. jamestbrewer's Avatar
    Did you try the TMo SIM cards in another phone to make sure they are active and can register on the network?
    07-06-09 06:00 PM
  7. Username00089's Avatar
    07-06-09 07:09 PM
  8. lazerus's Avatar
    Lol. ThreadEnvy.

    Posted from my CrackBerry at wapforums.crackberry.com
    07-07-09 01:41 AM
  9. Xpimp's Avatar
    Did you try the TMo SIM cards in another phone to make sure they are active and can register on the network?
    This is the million dollar question?
    07-07-09 01:47 AM
  10. kevinscrackberry's Avatar
    This should help. Options>Mobile Network>T-Mobile.

    After click on the MANAGE CONNECTION and make sure the Network is Checked
    07-08-09 02:55 AM
  11. PitoBlackBerry's Avatar
    i had a smiliar problem with sim card before, when i got my replacement phone, i put new sim card in and i had to activate it with customer care. if they dont apply it to your phone you wont get any signal, unless you used your old sim card that was activated already
    07-08-09 04:27 AM
LINK TO POST COPIED TO CLIPBOARD