Built for Business - Learn more about BlackBerry KEY2
  1. snowboardingpezo's Avatar
    I am getting an error message on a few of my applications when I try to open them. Let use Google Maps as an example:

    The error message reads "Application terminated: Google Maps has been denied the "Cross Application Communication" permission."

    Has anyone seen this before? I have updated to a new OS but that didn't work so now I'm back to the pre-installed .114. Any ideas on how to fix it?

    Like I said, it's not just Google Maps that does this to me (it's all third party applications that do it though) and yes, I have deleted some of them and reinstalled them.

    Well... I need some help.
    02-18-09 09:42 PM
  2. aristile's Avatar
    I think its very possible that you have installed a rogue 3rd party application and/or theme that is causing problems. Try to remove them one by one until you find the culprit. Please, let us know what you find out.
    02-18-09 10:53 PM
  3. snowboardingpezo's Avatar
    So i continued playing with it last night and found this:

    Go to:

    Settings > Options > Security Options > Application Permissions

    Highlight the application you want then hit:

    Menu > Edit Permissions

    Highlight:

    Interactions > Allow

    Also, if you expand the Interactions the first one underneath it reads "Cross Application Communication"

    Aristile, you are correct - this started happening first on my Pearl when I installed a new OS. I think that OS messed up my default settings. Then when I copied my messages, phone book, calendar, etc on to my new 8900 the default things must have copied with it. But everything works now - i guess I'll just have to change that default setting for all new applications.

    For the record... this took me FOREVER to figure out haha
    02-19-09 09:33 AM
  4. aristile's Avatar
    Awesome! Glad you figured it out. I guess you have the firewall on then? You might want to consider turning that off if you can.
    02-19-09 10:10 AM
  5. snowboardingpezo's Avatar
    There is an "Edit Default Permissions" in the menu, and I changed those, now my new applications that I loaded are automatically set up with the right permissions.... I guess in a strange form of a firewall. ALLOW ALL! lol
    02-19-09 11:47 AM
  6. clive48's Avatar
    Didn;t work for me. On Storm 9530 .151.. Loaded Swoosh Sudoku for Strom but get a/m error. All appl permissions are - Allow. Still same error. Anyone using Swoosh Sudoku on 9530?
    09-03-09 02:19 AM
  7. jdunn100's Avatar
    I just got my first smartphone about 3 weeks ago, BB Tour. Verizon navagator program is terrible and I downloaded google maps and ran into this very problem. This solve my problem.

    Thanks again for the effort and post.
    09-21-09 02:51 PM
  8. lowermi's Avatar
    Thank you Snowboard! Great info!
    01-29-10 01:31 AM
  9. resilient72's Avatar
    After loading the new 5.0 OS my Tour and downloaded Google Sync I received the message re "cross application". There isn't an Application Settings option in Security Options for the Tour. I had to go Options > Applications > highlight the app > Full Menu > Edit Permissions and changed Interactions to "Allow". Thankfully this is the only app with this issue.
    04-05-10 12:00 PM
  10. ngilmore's Avatar
    I Have a new Tour and followed the OS 5.0 fix listed above, but I can't change from the Custom to Allow. I wonder if this is set by my IT department, since I use the enterprise server.
    04-21-10 07:09 AM
  11. illusiondweller's Avatar
    I was having the same error message popping up at the end of the VZ Navigator loading process but after clicking "OK" to acknowledge the error message the Navigator continued loading without incident. Curious, I went ahead and deleted the Navigator program, made sure that my all my "Permissions" were set to "Allow" and I was still getting the error message, so I changed the "Cross Application Communication" permission to "Deny" and it loaded VZ Navigator without the error message! When I went back to check on the Permission status the Cross Application Communication was back to "Allow". I'm sure it was operator error but you might try this and see what happens! I'll admit, as well, that having to go online to change/delete your Favorites is not user friendly especially if you try to access the Navigator site on your Blackberry, on the go...NOT!
    Last edited by illusiondweller; 05-14-10 at 07:18 PM.
    05-14-10 07:15 PM
  12. zenith8181's Avatar
    Didn;t work for me. On Storm 9530 .151.. Loaded Swoosh Sudoku for Strom but get a/m error. All appl permissions are - Allow. Still same error. Anyone using Swoosh Sudoku on 9530?
    well, I just got a new 9550 today and spent whole day to make vz navigator work, every time hit the vz navigator icon didn't work said cross application, and I finally fixed myself, by go to options/applications/ there were vz navigation and the backup assistant in there so I deleted the backup assistant and the phone reboot itself after it turned back on I hit the vz navigator icon and it started downloading the navigation software itself and it worked.....
    10-02-10 02:02 AM
LINK TO POST COPIED TO CLIPBOARD