Built for Business - Learn more about BlackBerry KEY2
  1. CPT_Awesome's Avatar
    Alright i would like to thank everyone already for taking the time to help me out with my WiFi connection problem ,


    So i travel frequently between my parents house and my house, i bought the exact same identical router as them and have the exact same WEP passkey for both routers, it is able to connect fine and works perfectly at my parents house, yet when i come home and use the different profile to connect to my house, which has the exact same WEP key just a different SSID it fails.

    I have already tried changing my SSID to the same name as my parents router and even then it finds the router like normal however is still doesn't connect, even though the passkey is the same. I double checked on my Xbox 360 to see if can connect to my router with the same passkey and it connects fine. I have reset (unplugged and replugged) the router multiple times and also my BB.

    The only time it connects to my home router is when i change the security to None, in which case it does connect but as soon as i put the password on it again it cant connect all it has is a blackbox with a white line inside, next to the profile name, while checking out WiFi diagnosis i noticed all it keeps saying under the connection are is "trying" then it will change to a red x and then back to trying. As before if i take off encryption it works fine. however its weird because when i connect with a passkey to the router my BB doesn't even show up on the attached devices tab on my router homepage

    I have made sure i was using the mobile browser and also have tried changing the key from WEP to PSK and also even tried changing the passkey itself.

    So why does it connect to my parents router with protection and doesn't connect to my router when it has the same protection just a different SSID?

    Why does it only go online when i have no security but doesn't go online when i do have security? and i have double checked the passkey on my xbox so i know its valid

    i have already tried giving it a permanent IP address and it doesn't help, but i figure its best to let the router give it one so i undid that.

    Here is the problem report, which i was able to send only because i turned off encryption...i am so vulnerable now :P

    Wi-Fi
    Current Profile: Room_5
    SSID: Room_5
    AP MAC Address: **:**:**:**:**:**
    Security Type: Pre-Shared Key (PSK)
    Association: Successful
    Authentication: Successful
    Local IP Address: 192.168.1.3
    Signal Level: -51 dBm
    Connection Data Rate: 54 Mbps
    Status: Network acquired
    Authentication Failure Reason:
    Network Type: 802.11b/g
    Network Channel: 11
    Pairwise Cipher: TKIP
    Group Cipher: TKIP
    Gateway Address: 192.168.1.1
    DHCP: Successful
    Primary DNS: 192.168.1.1
    Secondary DNS: 0.0.0.0
    DNS suffix:
    Subnet Mask: 255.255.255.0
    Server Domain Suffix:
    Certificate: Not Applicable
    Software Token: Not Applicable
    L3 Auth:

    VPN
    Current Profile:
    Concentrator Address:
    Contact: N/A
    Authentication: N/A
    Secure Device IP:
    Status: VPN profile is not found.
    Resolving Concentrator: N/A
    Concentrator IP:
    Primary DNS:
    Secondary DNS:
    DNS Suffix:
    Secure Subnet Mask:
    Retry at:
    Session Lifetime:
    Re-login at:
    Failed Login Attempts: 0
    Certificate:
    Software Token:

    BlackBerry Infrastructure
    Address Used: //204.187.87.88:443
    IP Used:
    Connecting: Trying...
    Authenticating router: N/A
    Authenticating server: N/A
    Last Contact At:
    Sent via BlackBerry by AT&T

    THANKS SO MUCH FOR YOUR HELP

    The Captain
    Last edited by CPT_Awesome; 08-25-09 at 08:20 PM.
    08-25-09 08:14 PM
  2. aristile's Avatar
    Maybe you need to upgrade the firmware on your router?
    08-25-09 09:35 PM
  3. CPT_Awesome's Avatar
    i wish i have tried that also and all it says is "No new firmware updates are available" but thanks
    08-25-09 09:43 PM
  4. aristile's Avatar
    You can check the WiFi Guide link in my signature for a great thread on getting the WiFi setup.
    08-25-09 09:48 PM
  5. CPT_Awesome's Avatar
    i did and it has a section in step 3 on trouble shooting and i tried all of that already
    08-25-09 09:49 PM
  6. aristile's Avatar
    What brand and model routers do you have?

    You also might want to through all the comments in the WiFi Guide, there is information there on trouble brand/model routers, etc.
    08-25-09 09:51 PM
  7. J4ybl's Avatar
    I apologise now if this is already in the troubleshoot guide. Basicall I had to change the routers' network channel. I notice you have it at 11. Try different channels and see if that works - did for me!
    08-26-09 04:23 AM
LINK TO POST COPIED TO CLIPBOARD