1. thomo1974's Avatar
    Hi, phone won't start up- with a freshly charged battery, i put it in the phone. after a long waiting period, the phone displays the service provider screen(which was originally O2)and then will do nothing! Could anyone please help, many thanks Andy.
    04-20-12 02:02 PM
  2. Laura Knotek's Avatar
    04-20-12 02:20 PM
  3. PALeafs67's Avatar
    Take the battery out and plug the device into your PC then put the battery back in.
    sometimes the device needs a re-re-boot.
    If this does not work question how old is your device and how much memory do you have left..i know the 8520-8530 does not have much in the way of on board memory..
    you may have to start deleting apps..stuff you really don`t want or if you do want or need then its time for an upgrade of your device.
    thomo1974 likes this.
    04-20-12 02:24 PM
  4. siriphone's Avatar
    wipe with bbsak and reload with new os
    thomo1974 likes this.
    04-20-12 02:31 PM
  5. thomo1974's Avatar
    hi, have tried a few of these suggestions that you've given- but none have worked :-(
    04-21-12 07:14 PM
LINK TO POST COPIED TO CLIPBOARD