1. KVP28's Avatar
    Hello, new to this but experiencing some difficulties with my blackberry!

    I recently sent it away to the repair centre as one of the buttons wasnt functioning properly. I received it back today and turned it on to find a white screen with "No Application Linked, <Factory OS> on it. Could anyone please shed some light as to what i do to sort this?

    Much appreciated
    07-27-11 05:37 PM
  2. MobileMadness002's Avatar
    Have you tried reloading the OS yet?
    07-27-11 11:51 PM
  3. KVP28's Avatar
    No I haven't, how do i do that? Sorry I'm new to blackberrys!
    07-28-11 04:01 AM
  4. mobibiz's Avatar
    Hi KVP28, please go through these links Force wipe a blackberry that does not work. (All Models - All OS versions) use this to completely wipe your device. Once the device is wiped it will come up with a white screen saying 507 reload OS. Once that is done, follow the instructions on this page Error 507, Re-install /upgrade the os on the BlackBerry (All Models - All OS versions), basically in the second step you need to install the blackberry desktop manager either from the link given or you need to use the supplied CD with the phone. Once the installation is complete connect the phone to the PC, it will give you a message stating that the OS is unable to load up and do you with so update the OS. Go ahead with that and it will fix your phone.
    07-28-11 04:45 AM
  5. KVP28's Avatar
    Has that method been proven to work?
    07-28-11 05:16 AM
LINK TO POST COPIED TO CLIPBOARD