1. rnicklas1980's Avatar
    My service provider, Rogers, requires the net_rim_crypto module to run enhanced voicemail on my BB Curve 8520. How do I download this module?
    04-26-12 10:13 AM
  2. Fubaz's Avatar
    are you using a factory Rogers 8520 or an aftermarket unlocked or an unlocked from another carrier?

    have you called them? That would seem to be step 1
    04-26-12 10:32 AM
  3. BeaverJuicer's Avatar
    It is a part of your Operating System. It looks like only OS 6 and 7 devices are being supported. I do not see the 85XX listed as being supported.
    04-26-12 11:47 AM
  4. rnicklas1980's Avatar
    It's a factory phone from Rogers
    05-02-12 12:50 AM
LINK TO POST COPIED TO CLIPBOARD