1. natta444's Avatar
    Please someone help me because when i first got my blackberry i went on the internet and on youtube and i played a video and it worked put very pixelated. But now when i click to watch a video it says - 'An error has occured attempting to play media.'


    And no one say you need software 4.5 or over or something because why would the video play on the day i got it? But not now? i really want to watch youtube videos when i'm in college on my free lessons, it passes the time.
    So please some one respond or respond if you have the same problem, it would help me understand that maybe my phone isn't made to play videos
    11-05-09 04:12 PM
  2. Chop's Avatar
    I've always had issues playing YouTube videos straight to my BlackBerry... it's like they just don't get along naturally. I use Xenozu (it's free) and have zero issues. It plays YouTube videos, often clearer and in full-screen format. Give it a try. Hope it helps...
    11-05-09 04:39 PM
  3. diegonei's Avatar
    Looking for that answer too here.
    While you wait... have you considered playing Brickbreaker?

    People say m.youtube.com works. Give it a try and tell us how did it go.
    11-05-09 04:40 PM
  4. diegonei's Avatar
    I've always had issues playing YouTube videos straight to my BlackBerry... it's like they just don't get along naturally. I use Xenozu (it's free) and have zero issues. It plays YouTube videos, often clearer and in full-screen format. Give it a try. Hope it helps...
    We have the tendency to reply to the same threads lol.
    11-05-09 04:41 PM
  5. xxxxpradaxxxx's Avatar
    On 3G YouTube works "relatively" well.

    On WiFi YouTube works very well.

    However, On Edge YouTube works, but slowly, and pixelated.

    It all depends on your connection.

    Unfortunately, the 8520 only has access to WiFi and Edge.
    11-05-09 05:23 PM
  6. Chop's Avatar
    We have the tendency to reply to the same threads lol.
    I beat you by a minute... ha

    I don't usually have my phone on Wi-Fi only, so I hear it's faster, but ehhh... I just use my Xapp and it plays - well enough for the little snippet I'd be trying to see on my phone anyway.
    11-05-09 06:42 PM
  7. chustle925's Avatar
    For some reason Youtube and Blackberries dont get along with one another
    11-11-09 08:22 AM
  8. 7thsunday's Avatar
    Try this
    http://forums.crackberry.com/f141/yo...lution-361201/

    Posted from my CrackBerry at wapforums.crackberry.com
    11-12-09 02:23 PM
  9. kodian's Avatar
    Or maybe you can try using Bolt Browser

    Bolt Browser
    11-24-09 05:22 AM
  10. orangepeel's Avatar
    For some reason Youtube and Blackberries dont get along with one another
    I know.My 1st gen ipod touch looks great rendering youtube videos...my Storm looks like crap compared to it.

    Having said that,the ipod touch doesn't make phone calls very well.
    11-25-09 06:02 AM
  11. Eriktj's Avatar
    I use, as stated by another poster above, Xenozu from app world. It's free and easy to use. I haven't been able to watch youtube videos on the regular browser yet, and I find myself on the EDGE connection 99% of the time so far. However, Xenozu has worked fine for me. Happy youtube viewing!
    11-25-09 09:42 PM
  12. Redz120's Avatar
    I tried Xenozu and it worked thnx
    11-25-09 10:07 PM
  13. SaBu3011's Avatar
    It doesn't work for me and I have no idea why, it's soooo annoying!
    11-26-09 12:05 PM
  14. fafa0709's Avatar
    My boyfriend and I both have the 8520. His plays youtube video just fine. Mine wont. GRRRRRRRRR
    07-10-10 11:42 AM
  15. mangcool's Avatar
    For some reason Youtube and Blackberries dont get along with one another
    I agree... But not just YouTube, other video streaming websites too, like Vimeo.

    But, when watching video streaming, I'd really recommend using WiFi. Not your data service, especially when using the 8520.
    07-10-10 11:49 AM
  16. diegonei's Avatar
    My boyfriend and I both have the 8520. His plays youtube video just fine. Mine wont. GRRRRRRRRR
    There could be some APN settings missing. Check both phones under Options > Advanced Options > TCP/IP.

    I agree... But not just YouTube, other video streaming websites too, like Vimeo.

    But, when watching video streaming, I'd really recommend using WiFi. Not your data service, especially when using the 8520.
    And what about us, that cannot get youtube to work over WiFi, even if our lives depended on it?

    And about vimeo and other flash sites: There is no Adobe Flash for BlackBerry (so far), so there is no issue. It's simply a non-supported feature.
    07-10-10 09:09 PM
  17. psychotron's Avatar
    I use "Player For YouTube" (pretty creative name, huh?) and it works reasonably well. But as others have already stated, more so over wifi than Edge.
    07-10-10 09:19 PM
  18. emeraldgirl08's Avatar
    There could be some APN settings missing. Check both phones under Options > Advanced Options > TCP/IP.
    What should be checked on the APN?
    07-10-10 09:24 PM
  19. diegonei's Avatar
    What should be checked on the APN?
    If there is anything in there for starters.

    I could only use m.youtube.com after I had my carrier's APN in there. I heard some other carriers also do something similar, so if both phones are on BIS, on the same carrier, I'd give the APN a check.

    Still unable to use youtube over Wi-Fi thou...
    07-10-10 11:56 PM
  20. lyrikah's Avatar
    I can play videos on vuclip. I don't understand this at all.
    07-20-10 01:09 PM
  21. furqank's Avatar
    I am facing problem that youtube video does not play on my blackberry. I tried this using Wifi as I have no data plan. It shows buffering but does not play video.
    Please help me thanks
    12-16-11 08:58 AM
  22. jof26's Avatar
    i have the same problem now..before it worked well using wifi connection.i don't know now why it doesn't play at all.
    01-31-13 01:13 AM
  23. Jay panchal's Avatar
    dear friend

    please go
    home screen click
    1) option
    2) addvance option
    3) TCP
    see APN setting
    if its not correct
    then
    type correct informatio
    APN
    USERNAME
    PASSWORD
    06-28-13 03:15 AM
  24. Jay panchal's Avatar
    Clear all wap
    06-28-13 03:19 AM
  25. Percy_RKG's Avatar
    Looking for that answer too here.
    While you wait... have you considered playing Brickbreaker?

    People say m.youtube.com works. Give it a try and tell us how did it go.
    Hahaha L☺L I actually did that and end up loving it,I own an 8520 too and it sucks
    08-15-13 08:29 PM
LINK TO POST COPIED TO CLIPBOARD