1. anasheed1968's Avatar
    is this happening to any other 8520 users or is it just mine that is playing up
    each time i need to do battery pull or reboot it is taking 10 mins just to start up

    i have know idea what is happening to my 8520

    never had any problems until this week


    thanxs
    10-12-11 08:01 PM
  2. soll86's Avatar
    yup.. that`s the way it`s works :-)
    10-12-11 09:47 PM
  3. cassiachoochoo's Avatar
    Mine does too, I actually timed it afew weeks ago and it took nearly 11 minutes! .... Sucks

    Posted from my CrackBerry at wapforums.crackberry.com
    10-12-11 11:54 PM
  4. vaffluence's Avatar
    Yeah guy, it takes about that long to bootup. Frustrating but that's how it was made to be. My pc boots in abt 2 and half mins.
    My BB takes abt 10 mins! How pathetic!!!
    10-14-11 09:03 AM
  5. anon(4140245)'s Avatar
    it's quite normal... it's because there's too many apps on the phone, or too much content on the media card. Get rid of everything you don't need/use, and then try again. it should solve the problem at least it did when i had my 8520
    10-17-11 04:57 PM
  6. ransonju's Avatar
    Wipe and reload the OS. It will help for awhile. Getting rid of unused apps can help too.

    Posted from my CrackBerry at wapforums.crackberry.com
    10-22-11 03:44 AM
  7. taajir's Avatar
    Should be bout 5 mins
    But still so long

    Posted from my CrackBerry at wapforums.crackberry.com
    10-23-11 02:43 AM
LINK TO POST COPIED TO CLIPBOARD