1. jeffdoc's Avatar
    Hi Gang,

    I'm in a bit of a jam and hopefully someone here can assist. I've searched the forum for an answer but couldn't locate one.

    I have a Blackberry Curve 8530 and it's been experiencing some freezing from time to time.

    I decided tonight to backup all of my data and do a "Security Wipe" from the options menu.

    I selected both options, typed "blackberry" and clicked "wipe".

    I currently have the popup on my screen that says:

    "Erasing Information...
    Warning: Do not pull the battery out until erasing is complete."


    On top of this popup is the dreaded little Blackberry clock with the spinning hand going around and around (like an hourglass would on a PC when it's "thinking").

    I've attached a screenshot:



    It's been like this for 30 minutes now and doesn't appear to be responding any longer.

    I'm scared to pull the battery because it warns not to on the popup. I've tried to power it off with the Power Button but to no avail. No buttons do anything.

    What should I do? I've never had an issue like this and I'm worried that I'll be in for a lot of headaches if I pull the battery.

    Can anyone offer any advice or assistance? Have you run into this issue before? What happens if I pull the battery contrary to their warning not to?

    I'm kind between a rock and a hard place...and it's 1:38AM here...want to try to get this fixed before I go to bed if anyone is awake and reading this.

    Many, Many Thanks In Advance,

    Jeff
    Last edited by jeffdoc; 08-30-11 at 01:16 AM. Reason: Attached a screenshot
    08-30-11 12:40 AM
  2. Wretch 12's Avatar
    Give it another 30 minutes, mine did this so I just left it be as I didn't want to brick it. This worked out for me.
    08-30-11 12:54 AM
  3. jeffdoc's Avatar
    Thanks Wretch.

    I'll leave it for a while longer...or until someone offers a better alternative.

    I appreciate your reply.

    Have a great night.

    Cheers!

    Jeff
    08-30-11 01:00 AM
  4. jeffdoc's Avatar
    Update:

    Well, it's been almost 10 hours since the little clock popped up.

    The battery died overnight (as you know every BlackBerry does) even though I kept it plugged in with the charger.

    I woke up to a black screen and the phone was totally dead. Wouldn't even power on.

    I grabbed the USB data cable and plugged it in to my PC...and the red light came on....it charged for a few minutes and now I have a white screen with the hour glass spinning around. It's been doing this for about 5 minutes...so I'll leave it a bit to see if it progresses any further.

    I'll report back soon.

    Cheers!

    Jeff
    08-30-11 09:28 AM
  5. jeffdoc's Avatar
    Ok....good news...of sorts...

    The phone eventually powered up and proceeded to go through the wiping process and it now back up on the homescreen.

    The only problem now is that when I wiped it, the programs that I had downloaded previously are still on the device so it didn't totally wipe it as I had intended.

    I'll try another wipe and hope for the best.

    Cheers!

    Jeff
    08-30-11 10:00 AM
  6. jeffdoc's Avatar
    UPDATE:

    All back up and restored. Did a second wipe which went very quickly and smoothly.

    Thanks for reading and hopefully this will solve the lockup and freezing issues I had been having with my device.

    Cheers!

    Jeff
    08-30-11 10:27 AM
  7. BigBadWulf's Avatar
    If you reinstalled everything you wiped off Jeff, when the issue arises again, check the Event Log for errors. There's so many possiblities why this is happening. Hopefully, you're installing apps one each day, so if that's the problem, you'll have it nailed.

    Good luck mate!
    08-30-11 10:50 AM
  8. temenchat's Avatar
    Hi Jeffdoc, your solution is working here.
    I am having similar problem like yours
    Thank You very much for posting and updating your progress.

    Regards,
    Firmansyah
    01-28-13 03:08 AM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.