1. terrie89's Avatar
    So i have the curve 8520... it was working earlier today & then the battery completely died to the point my phone shut off. I went to put it on the charger and then got a battery symbol with a red x through it. I am not sure what that means but my phone won't turn on and won't charge. I tried taking the battery out and now it turns on but the symbol is still there and the loading bar is on the screen and it won't change. I also took outmy sim card & memory card. if anyone has any idea pleeeease help me.
    11-05-10 03:14 AM
  2. Fret Madden's Avatar
    So i have the curve 8520... it was working earlier today & then the battery completely died to the point my phone shut off. I went to put it on the charger and then got a battery symbol with a red x through it. I am not sure what that means but my phone won't turn on and won't charge. I tried taking the battery out and now it turns on but the symbol is still there and the loading bar is on the screen and it won't change. I also took outmy sim card & memory card. if anyone has any idea pleeeease help me.
    Only time I've seen that icon is when I have my battery out while the device is plugged in; sounds like you have a bad battery.
    11-05-10 04:14 AM
  3. ocmagnum's Avatar
    Ya I realize the two are different but that icon shows up on my laptop and then it tells me, consider replacing my battery. It sounds like u need a new battery. Maybe u leave it on the charger longer than needed?

    Posted from my CrackBerry at wapforums.crackberry.com
    11-05-10 11:20 AM
  4. RWWackostu's Avatar
    Ya I realize the two are different but that icon shows up on my laptop and then it tells me, consider replacing my battery. It sounds like u need a new battery. Maybe u leave it on the charger longer than needed?

    Posted from my CrackBerry at wapforums.crackberry.com
    The chargers have a component in them that prevents over charging. I charge mine every night whether it needs it or not.

    To answer the OP, that happens when you completly die (discharge the battery conmpletly). Leave your device off (Push and hold red button for power off) , and plug it in to the wall charger. Let it charge for 30 minutes. Unplug and turn on. Let it boot up and check the icon. It should not have the X now. Then plug it back in and let it charge fully.

    I would also recommend charging your battery overnight whenever you can so you dont completly discharge it. L-ion batteries like to be charged often.

    Welcome to the forums.
    Last edited by RWWackoStu; 11-05-10 at 03:40 PM.
    11-05-10 03:14 PM
  5. Anupam Singh's Avatar
    I having the same problem..... and I am not able to turn on my BB. Please let me know how to turn on?????
    12-31-12 04:45 AM
  6. Deanig_12's Avatar
    connect blackberry to pc without battery and start reloading the os..when it reaches the stage where it say connecting to JVM, insert the battery while the phone is still plugged in...give it a few minutes and it should connect and be good to go.
    01-02-13 06:08 PM
  7. Uzume13's Avatar
    I have the same issue, just put a new battery in today and the same thing happens. Seems to be a common issue as I have looked at several forums with a lot of people reporting this.
    04-05-13 07:47 PM
  8. ihaveabbcurve9320's Avatar
    The ssame thing happned with me this morning, whut I did was leave it in the charger for 10 mins, take it out, and repat until u see the rebooting sign. U don't need a new battery for this!
    04-27-13 11:07 AM
  9. Junahari Khadka's Avatar
    Buy new battery
    08-03-13 08:56 PM
  10. fzeesta hoque's Avatar
    hi tere,i have had a problem with my blackberry,i start it up,then it loads and a white screen saying"blackberry"on it,so i tried so many times taking the battery off and charging it,it worked then again the same thing happened,so i decided to order a new battery,then it worked fine for around 2 weeks,now the same problem has occured and i tried various things.please help.thanks a lot
    01-05-14 09:56 AM
  11. Adrianna22's Avatar
    Hi,

    Hope this response isn't too late for everyone- but you can be sure it is a battery issue. I just incurred the same issue attempting to troubleshoot my clients phone in-store and a replacement of the battery solved the issue.

    You don't need a 'new' battery, but one that is in relatively good condition (no swelling, water damage (shown as a red mark on the litmus paper) etc).

    This symbol basically says "No good battery'.

    Hope that helps,

    xo!
    01-21-14 12:17 PM
  12. systemvolker's Avatar
    Connected but not charging. I hope you didn't break your usb connector on the phone.
    Posted via CB10
    01-21-14 12:35 PM
LINK TO POST COPIED TO CLIPBOARD
We have updated our Privacy Policy and Terms & Conditions. Please check them out.