1. tonkie93's Avatar
    Please can anyone help,my 8520 will not load fully,the bar only goes 2 thirds of the way across,so I cant do anything,so is there anyway to do a factory reset or any pointers on how the get to load fully.

    Thanks in advance
    02-18-12 02:50 AM
  2. miz_pimp's Avatar
    Hi, you can try starting your device in Safe Mode, by holding the back (arrow) key while your device is starting up. Hopefully that will help.
    02-18-12 02:59 AM
  3. tonkie93's Avatar
    Hi, you can try starting your device in Safe Mode, by holding the back (arrow) key while your device is starting up. Hopefully that will help.
    Thanks miz

    I take it you mean the black arrow key on top of the device,well if so,it still only went 2 thirds of the was across
    02-18-12 04:01 AM
  4. oshaneharriott's Avatar
    Have you tried removing tha battery?
    02-18-12 04:28 PM
  5. tonkie93's Avatar
    Thanks alot
    02-24-12 02:13 PM
  6. tonkie93's Avatar
    Thanks all
    02-24-12 02:13 PM
  7. tonkie93's Avatar
    Thanks everyone
    02-24-12 02:14 PM
  8. tonkie93's Avatar
    Sorry I will expain soon
    02-24-12 02:14 PM
  9. tonkie93's Avatar
    I have to have posted a least 10 post before I can use links on other threads
    02-24-12 02:15 PM
  10. tonkie93's Avatar
    So only 3 more
    02-24-12 02:16 PM
  11. tonkie93's Avatar
    Blimey have to wait 30 seconds inbetween posts
    02-24-12 02:17 PM
  12. tonkie93's Avatar
    Last one,sorry but had to do it
    02-24-12 02:17 PM
LINK TO POST COPIED TO CLIPBOARD