1. Loufa's Avatar
    I've been using a today theme for a long time now and everything was great. All of the sudden my calendar started acting up on the home screen. It only shows a few random appointments from 5/10 on. I have been on the phone for the past three days with Verizon and with RIM and we've done the following:

    Deleted and resent service books
    Battery pulls
    Uninstall and re-install theme
    Handheld wipe (yikes!!)
    Backup and restore

    Nothing worked! I sync my curve with Microsoft Outlook and everything is there, everything is in my calendar on the curve but it doesn't show up on the today screen. I've even tried downloading other today themes and it's the same thing...all except for the dimension one the phone came with. That one seems to work. I don't like that one though because it's TMI...I just want the calendar. It is sooooo frustrating. I'm hoping that someone here can help.

    04-24-09 11:44 AM
  2. BusDriver's Avatar
    This has been happening for A LOT of people - go into your advance settings - applications - and re associate your primary email with your device.. it will fix the problem.
    04-24-09 11:57 AM
  3. Loufa's Avatar
    Wow, thanks for your reply. I'm so happy there might be light at the end of my long tunnel!! I went into my applications file and don't find anywhere to associate my e-mail. What should I look for.
    04-24-09 12:12 PM
  4. ERDude's Avatar
    Go to options, advance settings, default services then select the calendar you want or to delete the (cical) calendar(s) you don't want to use go into service books.. I delete all calendars and just use the device default.
    04-24-09 12:35 PM
  5. ERDude's Avatar
    PS - Today themes only work with one calendar. It gets all confused if you use more than one.
    04-24-09 12:39 PM
  6. Loufa's Avatar
    Thanks for your reply. I deleted the service book for my secondary CICAL and made sure my default calendar was my main one. Did a battery pull and still no change. This is sooooooo frustrating!!!
    04-24-09 12:54 PM