Built for Business - Learn more about BlackBerry KEY2
  1. barnacles's Avatar
    I have searched and found a few threads with similar issues but every one was solved by a battery pull. I have a text message that I sent a month or so ago at the bottom of my list. I can select delete but when I do it doesn't delete. I have tried to mark prior opened and delete, ive tried to delete prior, ive tried a battery pull and still nothing. Any ideas?
    09-18-09 12:08 AM
  2. iowabowtech's Avatar
    If you purposely or accidentally saved the message, you can check that by opening SMS, press menu button and select "view saved messages". If it shows up there, you should be able to highlight it and delete.
    09-18-09 12:19 AM
  3. barnacles's Avatar
    Yes it is in my saved and I can go into that and delete it making it disappear from that list. But when I back out its in my messages again and if I go into saved its back in there too.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-21-09 09:54 PM
  4. junomoss's Avatar
    i have the same problem! help please!!!
    09-21-09 10:19 PM
  5. barnacles's Avatar
    Yeah its really frustrating. I'm about rdy just to flash to os in hopes of that resetting everything but I really don't wanna lose everything else if I don't have to.

    Posted from my CrackBerry at wapforums.crackberry.com
    09-22-09 09:07 AM
  6. nyparkchic21's Avatar
    I deleted my saved messages by going to the "saved" folder and deleting them there...AND by then deleting them from the sent messages...hope it helps....
    09-22-09 12:26 PM
  7. barnacles's Avatar
    Yeah tried this but no dice. like I said when I delete it from saved it goes away but when I go to my messages folder after that n try to delete it nothing happens. Then when I go back into saved its there again

    Posted from my CrackBerry at wapforums.crackberry.com
    09-22-09 12:36 PM
  8. nyparkchic21's Avatar
    Hmmm....and you tried a battery pull and everything and still no luck?
    09-24-09 12:54 PM
  9. redhdgirl417's Avatar
    Not to put you down, but you did a battery pull WITH the phone on?
    09-24-09 02:03 PM
  10. restrada13's Avatar
    This has happend to me a couple of times when I have a Today theme running. After "deleting" the item, I usually change the theme, wait a couple of days, then come back and it has disappeared. Hope this helps you out.
    09-24-09 04:20 PM
  11. barnacles's Avatar
    Yes I have done the battery pull. I have tried to switch themes even tho I don't use the today theme will still no luck. Ahhh

    Posted from my CrackBerry at wapforums.crackberry.com
    09-27-09 10:15 PM
  12. barnacles's Avatar
    alright to whoever else was having this problem i plugged my phone in and opened up manager. from there i deleted all the sms messages in the phone and it worked
    Last edited by barnacles; 09-30-09 at 03:02 PM.
    09-30-09 12:03 PM
LINK TO POST COPIED TO CLIPBOARD