1. pliko's Avatar
    My 6 months old blackberry curve 8330 unit still works and connects to the Bell network, but stopped transmitting and receiving voice, while a call is actually connected. Problem applies when using the unit alone (no headset) and with a bluetooth headset. This problem started spontaneously,with no warning or apparent physical cause.

    The only situation where I can make/receive voice calls is with a wired headset. Which indicates that there seems to be an issue with the mechanism that detects the physical connection of the wired headset in the phone jack hole: even when there is no wired headset plugged in, the unit thinks there is one, and deactivates the default micro and the bluetooth connection.

    Anyone has experienced this before? I want to make try every solution possible path myself before sending the unit for hardware repair (long & painful process).
    12-17-09 09:38 AM
  2. jeffh's Avatar
    If it's six months old and you are the original owner, just exchange it for a refurbished unit under warranty. That will be much quicker and cheaper than attempting to repair it.
    12-17-09 10:50 AM
  3. KillYouWithMyMind's Avatar
    Agreed. However if you attempt to repair it yourself, definitely browse thru the Curve forums on this site or look up a disassembly video on youtube. I personally find it easier to watch a video.

    And to answer your initial question- no, I have never heard of this issue. I do agree with your diagnosis though, sounds like you are correct.
    12-17-09 11:28 AM
LINK TO POST COPIED TO CLIPBOARD