Built for Business - Learn more about BlackBerry KEY2
  1. MsTreoDiva's Avatar
    I made a mistake and dropped my phone in some water a few weeks ago Now the LED light stays a constant red. I took it to Sprint and they told me I have get a new through the insurance b/c it has water damage Anyone know how to turn it off w/o me getting a new one from the insurance?
    02-21-09 02:00 PM
  2. lastraid's Avatar
    Water damage is a funny thing, you might be SOL and need to get another device. If everything is working okay, have you tried a battery reset?
    Last edited by lastraid; 02-21-09 at 02:21 PM.
    02-21-09 02:19 PM
  3. Chicklet's Avatar
    Assuming you disabled the led ?? Have you tried a wipe and re-install ?

    Posted from my CrackBerry at wapforums.crackberry.com
    02-21-09 02:24 PM
  4. Iceman's Avatar
    I think most of us are just amazed that it still powers on after water damage...very lucky!
    02-21-09 02:26 PM
  5. bravy02's Avatar
    If you have insurance through Sprint's Total Equipment Protection (TEP) I'd suggest placing an insurance claim and paying the $50 deductible to receive a refurbished device.

    I just read over the info that Sprint/Asurion sent me in the mail and in April the deductible for any Sprint BlackBerry is going to increase to $100.
    02-21-09 03:43 PM
  6. MsTreoDiva's Avatar
    Yeah its working fine, I caught it immediately. It actually fell in a cup of water and I let it dry out. I could see the water mark in screen as it was drying out. It did take a few days..

    Yes I tried to disable the LED and I took it into Sprint to get them to fix it. No dice. They told me to get a new one from the TEP and wow $100! Thats a mess! I paid $100 for it I bearly want to pay $50 considering Its not a year old yet..
    02-21-09 04:33 PM
  7. MsTreoDiva's Avatar
    No I did not try to wipe and re-install. Even though you back up and sync you do loose things when you do this. I did this when I got a replacement phone from the store when I had a re-boot problem.
    02-21-09 04:48 PM
  8. crackvegas78's Avatar
    No you should not lose anything if you back up first
    02-21-09 04:52 PM
  9. MsTreoDiva's Avatar
    Ok I backed up earlier should I do that again?
    02-21-09 04:56 PM
  10. MsTreoDiva's Avatar
    Then once I back up how do I wipe it clean?
    02-21-09 04:57 PM
  11. xliderider's Avatar
    Then once I back up how do I wipe it clean?
    You can use JL Comander, link in first post:

    http://forums.crackberry.com/f3/how-...l_cmder-53502/

    Or CrackUtil, .zip file at bottom of first post:

    http://forums.crackberry.com/f35/crackutil-85617/

    Or CrackMem, .zip file link at bottom of first post:

    http://forums.crackberry.com/f35/cra...eleased-52044/

    Using CrackMem, you can also pick and choose which modules you want to load to your phone during the OS install to save on your device memory.
    02-21-09 05:58 PM
  12. brewster_37's Avatar
    Do you have vlingo installed. That caused problems on mine
    03-19-09 05:36 PM
  13. gbean's Avatar
    I have the same problem with my 8830 from sprint.
    Fell in a muddy hole of water 2 feet deep.
    I pulled the battery and set it in the sun for two hours and it is in perfect shape.
    The only problem is that darn LED. It is dimmer than the notification flash, but it is on red all the time, even when "powered off."
    I wonder if it is some sort of water damage indicator?
    05-22-09 01:17 AM
  14. craign1317's Avatar
    i had the same problem and i had to use insurance to get a new phone there was nothing that i could do.
    05-22-09 07:53 AM
  15. lastraid's Avatar
    I wonder if it is some sort of water damage indicator?
    Yes there is, there should be a sticker both on the battery and in the battery well of the device.
    05-22-09 08:15 AM
LINK TO POST COPIED TO CLIPBOARD