1. imcrackin's Avatar
    I've had my Curve for a few months now but all of a sudden I can't hear people when they call my phone. They can hear me but nothing coming out on my end. The volume is turned all the way up but still can't hear anything. Has anyone else had this problem? I can hear my music player so don't think it is a speaker or volume problem. Help me please!!!
    01-21-09 11:59 AM
  2. nufan4115's Avatar
    Do you open sms with audio? there was a problem with opening them and it shutting off your speaker....happened to me........remove your battery and that should get your speaker back.....what os are you running? i have upgraded to 4.5.o.77 and have had no problems since
    01-21-09 12:07 PM
  3. ST79's Avatar
    Did u try a battery pull ?
    01-21-09 12:07 PM
  4. imcrackin's Avatar
    battery pull worked...thank you so much!!!!
    01-21-09 12:15 PM
  5. Reed McLay's Avatar
    Good call, that is a well known bug in the 8330.

    It is caused by interrupting certain non BlackBerry audio files. The speaker is not released correctly.

    The quick fix is to activate Voice Activated Dialing, that will free the speaker and let you continue a call. Pulling the battery does the same thing, but interrupts the call with a full restart.

    The bug has been corrected in v4.5xx upgrade.
    01-21-09 01:53 PM
  6. David Cadman1's Avatar
    Hi I just wanted to say a really big thanks... I pulled the battery and it worked... we were going nuts trying to find a solution... restart didn't work, and couldn't find anything in set up... tried flipping the cover up, and down squeezing the cover, NADA!! was getting worried I would be ditching the phone and buying a new one... then saw a post from 2009, about taking the battery out... it was a last resort... Whaahoo!! If I sound a bit over the top, I'm on gov't pension and connectivity is important for us... so this is a biggy... Crackberry comes through again...

    forgot: the phone is a BB Torch so there is still something wrong with the software... but there is a fix...
    05-06-16 04:47 PM
LINK TO POST COPIED TO CLIPBOARD