Built for Business - Learn more about BlackBerry KEY2
  1. Balbs's Avatar
    Got my BB Curve/BIS in May. Set it up without problems until one email address stopped receiving emails about 10 days later. Uninstalled and figured I would just reinstall. Now the BB says it's an invalid address and/or the server will not support it. I've been both into the Sprint store and at the top line tech support on the phone and they all say they have not seen anything like this (we go through adding server info, etc...). I can login easily via webmail and others at my company (a .org) have no problem adding their addresses. I even have other generic work emails on my BB, just not this one specific account (my main address). Any ideas?
    Last edited by Balbs; 09-19-09 at 04:07 PM.
    09-19-09 03:26 PM
  2. obaquerizo's Avatar
    Ok if is a company email, propably this could happens, in my company the email insted of been the username until before @.
    Ex: xxxxx@ been xxxxx you username, some companies use the username all the address like xxxxx@xx.org like yours, in my company did this an that make imposible to put the address, cuase the username is xxxx@xx.org instead of only xxxx talk to your company system department to see if this is how the configure they mail, that could be the problem

    Posted from my CrackBerry at wapforums.crackberry.com
    09-19-09 06:30 PM
  3. larrygump's Avatar
    or its a security issue.....if it was working then it stopped 10 days later
    09-19-09 07:00 PM
  4. Balbs's Avatar
    I'll give it a shot, thanks. Yeah, other accounts at the company work fine, just not my particular address. I'll see what they say.
    09-19-09 11:47 PM
  5. Balbs's Avatar
    Unfortunately, no dice. System Admin at the office says it's not a security issue, and we looked at the username issue mentioned above and that's not it either. Very strange. Other thoughts?
    09-22-09 03:25 PM
  6. j.nelson01's Avatar
    If not accepting the server name try typing in the servers ip address i've seen that working several times.
    09-22-09 05:43 PM
  7. Balbs's Avatar
    Thanks, I'll give it a shot. I tried adding other folk's email addresses at the company to my BB, went through fine. But tried adding my email on other phones, wouldn't validate. I am tending to think somehow RIM or Sprint flagged my email address for some reason, not sure why. Is that possible?
    09-26-09 03:53 PM
  8. plunkingtom's Avatar
    can your tech completely delete the email address on their server then reinstall it and then try and get it back on your berry… or just get your named changed to john or something better check with your wife first.
    09-26-09 04:13 PM
  9. Balbs's Avatar
    can your tech completely delete the email address on their server then reinstall it and then try and get it back on your berry or just get your named changed to john or something better check with your wife first.
    Thanks. It's definitely a good idea, unfortunately they can't delete the email and start over. Already talked that over with them. I'd lose too much at the moment.
    09-30-09 07:55 AM
LINK TO POST COPIED TO CLIPBOARD