1. CosaterKrazy's Avatar
    I am having problems receiving MMS messages on my Curve 8330. I have an Alltel phone, and it worked fantastically for the first few weeks that I had it. Then 4.5 OS came out and I decided to upgrade... but there went away MMS capabilities.

    Anyone know how to make this work... without downgrading my OS?
    04-27-09 10:28 PM
  2. SofaKingKev's Avatar
    the option to mms is gone? what OS did you upgrade to?
    04-27-09 10:31 PM
  3. CosaterKrazy's Avatar
    MMS option isn't gone. I can compose and send MMS messages. The catch is - I can only successfully send messages to people on the Alltel Network. I cannot recieve them from any network not can I send them to anyone else (unless its an Alltel phone).

    My current OS is 4.5.0.89
    04-27-09 10:34 PM
  4. SofaKingKev's Avatar
    you might want to upgrade from that.. but first, go to options>advanced>host routing table>menu>register now.. then do a battery pull(phone on, pull out the battery and replace in 30 seconds) then see if you can do a test mms from someone to see if it works. if that doesnt help, you might want to upgrade to 4.5.0.138 that is on a sticky at the top of this forum
    04-27-09 10:39 PM
  5. CosaterKrazy's Avatar
    Should I wait for it to do its thing then do a battery pull or immediately pull it?

    And, I want the OS for the 8330... not the 8330m, correct? I'm not too sure what the "m" stands for in this case.
    04-27-09 10:41 PM
  6. SofaKingKev's Avatar
    press #4357* SEND and if the info near the top says devicemeid# you have an 8330m if it says device esn# you have an 8330.

    and just exit out of the options and do the battery pull
    04-27-09 10:47 PM
  7. grandpa dan's Avatar
    I am running that exact os on alltel on my 8330 and have no mms issues. That os came installed on my bb from alltel. My understanding of the more current os upgrade is that it offers a patch for a sync issue with this os. My guess would be a setting got switched at the time you did the upgrade not an os issue.

    Posted from my CrackBerry at wapforums.crackberry.com
    04-27-09 10:51 PM
LINK TO POST COPIED TO CLIPBOARD