Black Friday deal team is live right now!

Check out the hottest Black Friday Deals!

Expand Minimize
  1. Joe4PNE's Avatar
    Hi, my blackberry 9300 (curve 3g) seems to of got it self "nuked". i have tried a few fixes and have had no luck.

    When i try the fix using app loader it does not work as it does not display "USB-PIN: UNKNOWN" it just displays my devices Pin. i have tried this many times and watched closely and it has not once said USB-PIN: UNKNOWN.

    Also When i try to use the fix using blackberry desktop software by clicking update when it is plugged in i get stuck on "Reconnecting to JVM" and a pop up appears with the message

    "Application loader was unable to connect with your device. Please reconnect your device, enter the password, if required, and click retry."

    i do have a password on my blackberry and i enter this when promoted to at the start of the update. i have followed the steps in the guides closely and have had no luck.
    Please Help,
    Last edited by Joe4PNE; 06-25-12 at 04:52 PM.
    06-25-12 04:46 PM
  2. flash24's Avatar
    Remove the battery, plug it in and then run the app loader. It should recognize it.
    06-25-12 07:35 PM
  3. headakatsuki's Avatar
    Hi! i have tried semi-successfully to get to the third page of 'apploader'... but instead of it giving me options for applications i want to add or remove, it just says "The BlackBerry Desktop Software does not have Blackberry Device Software for the device that you have connected to the computer. Contact your wireless service provider or system administrator" -- in shallowed grey font... but i've used my desktop software to organize my blackberry before, so i'm PRETTY sure it has the software for my blackberry.... sooo... any suggestions...???
    11-15-12 12:31 AM
We have updated our Privacy Policy and Terms & Conditions. Please check them out.