1. Omega8c's Avatar
    I Have a Rogers Blackberry Curve 9300 ..

    According to Rogers Website it supports

    GSM Bands:
    850/900/1800/1900
    HSPA Bands:
    850/1900/2100

    Wind Mobile Supports the
    AWS 1700/2100 Bands

    The phone is unlocked and running on the older *Edge* network but that is roaming on the rogers network ..

    Should/Will this phone connect to the Wind Service on the 2100 Band? or am i sol?

    Thanks in advance
    06-17-12 07:08 PM
  2. BigBadWulf's Avatar
    You'd need the 1700 band to receive 3G on Wind. So yes, SOL indeed.
    06-17-12 11:36 PM
  3. blackberry-unlocking710's Avatar
    If you want to get fast speed data connection (3G) with WIND by using unlocked Blackberry device you should get a Blackberry that supports the same bands (2100 / 1700)

    If your Blackberry is from Mobilicity and has been unlocked it will work with WIND's fast data connection..
    Also, a US Branded T-mobile Blackberry that has been unlocked will work with WIND sim cards the same way..

    Unlocked Rogers / Bell / AT&T Blackberry that used with WIND will give you EDGE (2G) speeds.
    06-19-12 01:45 AM
  4. SoUnCool's Avatar
    Hello, I have a Rogers BB Curve 9300, it is unlocked, I am trying to use it with WIND SIM The SIM is for phone only, so I dont care if I get data 2G or 3G. I get edge or GSM coverage but it always show WIND AWAY. Which is fine as long as WIND is not charging me for romaing, but problem is that it keep loosing connection, and connection status goes to SOS until I scan and connect to network manually or turn off and turn back on the wireless, any help will be appreciative

    Also I can receive phone calls but cannot make outgoing calls, it tries to call out and then the call drops


    thanks
    11-10-12 08:38 PM
  5. Invididom's Avatar
    Hello, I have a Rogers BB Curve 9300, it is unlocked, I am trying to use it with WIND SIM The SIM is for phone only, so I dont care if I get data 2G or 3G. I get edge or GSM coverage but it always show WIND AWAY. Which is fine as long as WIND is not charging me for romaing, but problem is that it keep loosing connection, and connection status goes to SOS until I scan and connect to network manually or turn off and turn back on the wireless, any help will be appreciative

    Also I can receive phone calls but cannot make outgoing calls, it tries to call out and then the call drops


    thanks
    Hey, anyone found a solution to this? As well, I'm using an unlocked Blackberry 9300 on Wind- it only displays SOS, or occasionally WIND AWAY, no matter where I am in the GTA.
    11-25-12 04:31 PM
LINK TO POST COPIED TO CLIPBOARD