01-06-18 12:23 PM
257 ... 891011
tools
  1. Mr4aces's Avatar
    Just traded in my Classic today for another one. No more charging problems now. YAY!!!!
    Since you have the SQC100-2 get a wireless charger. This is a must have!

    PIN 2COF829A
    10-26-15 11:14 PM
  2. tonyblu's Avatar
    I am not able to charge my BB classic since the upgrade to 10.3.2.
    The OEM charger that came with it gave an error that it was the wrong charger; other chargers just manage to get it charged for a few days, and I have to go testing for another charger or USB cable that will work almost on a weekly basis.
    This morning, the charger in my office that used to work, failed so the phone has been off all day. Strange, mt Lumia 730D gets charged by all these same chargers that failed to work on the BB-classic.

    I don tire.

    Sent from my Lumia730D phone.
    10-24-16 02:49 PM
  3. undefinederror's Avatar
    No issues here!

    Posted via CB10
    10-25-16 12:46 AM
  4. slagman5's Avatar
    I think most people not having issues would not bother to come here to comment. But anyway, now that I'm here, I'm not.

    Posted without the aid of AutoCorrect with my physical keyboard via CB10
    10-25-16 12:00 PM
  5. keyboardweeb's Avatar
    My Classic is only ~10 months old (from time of purchase) and I'm not having charging issues. I sure hope I don't have any issues. It'd be the first time I had such a problem with any phone.
    10-25-16 12:26 PM
  6. scrotesmagoat's Avatar
    No issues so far

    Posted via CB10
    10-25-16 05:25 PM
  7. aventurine's Avatar
    No charging issues on my 21-month old SQC 100-4 Classic. Was recently gifted with a brand new unlocked Classic, and it arrived with a totally dead battery. Was a little worried that i wouldn't be able to charge a dead phone after all I'd read about that issue. Plugged it in and it charged no problem. The LED cycled green/yellow, then after awhile (as i recall) it blinked red. But normally the red LED has never displayed when charging, have often wondered why it doesn't. It doesn't on either of my Classics, although it did for that one initial dead-battery charge.

    Posted via CB10
    10-25-16 06:15 PM
  8. Mtags_99's Avatar
    12 months and no charging issues with my Classic 10.3.2. I use mostly the original BlackBerry charger but from time to time I use also other brands. Never had a problem.

    Posted via CB10
    10-26-16 12:39 AM
  9. arif b santoso's Avatar
    I'm not.

    Posted via CB10
    10-26-16 03:09 AM
  10. mmk1954's Avatar
    No problems here! 2nd anniversary coming up. All up to date. I do notice that recently video and audio use will take a lot of the battery power. My Cobalt Blue Classic is the only phone I have, no landline at home so it gets a lot of use.


    Using my Cobalt Blue BlackBerry Classic :-)
    10-26-16 08:37 AM
  11. JAS0NB0URNE's Avatar
    There is a thread with people posting that they are not able to charge their Classic with the device powered down - I am wondering if there are people using Classic who DO NOT have this problem (i.e. I am wondering if this is an isolated problem, or a widespread problem).

    Thanks in advance for any responses.
    Have never had an issue to this day charging it while on or off.

    Posted with my  Classic
    10-26-16 08:42 AM
  12. FJPF's Avatar
    I had an issue with my Classic. It used to charged till 60%, and when I turn it off it used to wipe all the information on the phone. There's this solution for Windows/Mac users that worked for me.

    Here's the link: All data is wiped after a restart of the BlackBerry 10 smartphone and a blue LED is displayed during boot up
    10-26-16 12:09 PM
  13. hplovecraft's Avatar
    This is a nearly two year old thread about some isolated charging problem back then...and now I am part of it.

    So: No charging problems here ;-)

    CB10 on my Classic
    10-26-16 02:44 PM
  14. stormgustwz's Avatar
    got my Classic in Jan 2016, no probs in charging at all
    10-26-16 09:39 PM
  15. alfred442's Avatar
    7 month old Classic here. No problems so far. =)

    Pinoy Whiteberry Classic SQC100-1/10.3.2.2876
    10-28-16 06:09 AM
  16. DVM3's Avatar
    Zero problems here, had for a year and still great battery life.

    Posted via CB10
    10-30-16 11:28 AM
  17. erguduju's Avatar
    No problems over an year and a half old.
    11-01-16 06:16 AM
  18. iMasterus7's Avatar
    OK, I do have a problem Brand new BlackBerry Classic (QWERTZ). Won't charge and won't turn on. Manufacture date is 04.05.2016. Seems like the battery is completely dead. Plug it onto my MacBook Air and waiting, as one BlackBerry KnowledgeBase article suggested.

    Posted via BlackBerry Passport Silver Edition
    12-23-17 01:52 AM
  19. Zebra 99's Avatar
    Don't have problem. Even updated to OS10.3.3.1435

    Posted via CB10
    12-23-17 02:58 AM
  20. Cainamzak's Avatar
    OK, I do have a problem Brand new BlackBerry Classic (QWERTZ). Won't charge and won't turn on. Manufacture date is 04.05.2016. Seems like the battery is completely dead. Plug it onto my MacBook Air and waiting, as one BlackBerry KnowledgeBase article suggested.

    Posted via BlackBerry Passport Silver Edition
    I have a brand new sealed one that was also stone cold dead when I got it but it managed to wake up - but that took less than a half hour.

    Sometimes lithium ion batteries need to be jump started to be recognized for the charging cycle to work.

    Had to jump two phone batteries with a 9 volt that sat too long this year. Also heard heating the battery may help - perhaps try to put it on a heat vent in your house, hair dryer, direct sunlight.

    The battery is replaceable if needed. Do you at least get the dead battery symbol?
    12-23-17 08:34 AM
  21. iMasterus7's Avatar
    I have a brand new sealed one that was also stone cold dead when I got it but it managed to wake up - but that took less than a half hour.

    Sometimes lithium ion batteries need to be jump started to be recognized for the charging cycle to work.

    Had to jump two phone batteries with a 9 volt that sat too long this year. Also heard heating the battery may help - perhaps try to put it on a heat vent in your house, hair dryer, direct sunlight.

    The battery is replaceable if needed. Do you at least get the dead battery symbol?
    No sign of dead battery. Kind of weird to deal with irremovable battery of BlackBerry Classic by getting it out and heating or something Anyway, thanks for the tip! Will try it once I get home tonight. I am drunk and will torture this faking Classic

    Posted via BlackBerry Passport Silver Edition
    12-23-17 10:39 AM
  22. Alucard-4417's Avatar
    I got a German BlackBerry Classic and it's working fine and the battery life can stay with me a hole day with mobile data on, and if I put it on sleep mode it can last till 3 days

    Posted via CB10
    12-23-17 10:54 AM
  23. Cainamzak's Avatar
    I left my old 9650 with the battery cover off over a house register with the cord plugged in and then it just started to charge on its own.

    There's a video on YouTube on how to take the back cover off the Classic.

    If you choose to do the jump start method there's also videos on YouTube as well - but I've only tried that on a battery not a ribbon cable. It only takes a few seconds and is much faster than doing the heating method.

    Mine did the red / green light while it woke up - never saw that on a BlackBerry before. Something I noticed right away.

    Cheers!
    12-23-17 10:58 AM
  24. iMasterus7's Avatar
    Alas, nothing helps so far.

    Posted via BlackBerry Passport Silver Edition
    12-24-17 01:32 AM
  25. Cainamzak's Avatar
    Alas, nothing helps so far.

    Posted via BlackBerry Passport Silver Edition
    Are you able to return it?

    If not, maybe just buy a new battery and swap it out to see if that is the problem.
    12-24-17 08:09 PM
257 ... 891011

Similar Threads

  1. How do I sync my Fitbit with my Z10?
    By CrackBerry Question in forum Ask a Question
    Replies: 7
    Last Post: 02-15-15, 09:42 AM
  2. Classic on O2
    By bblasl in forum O2
    Replies: 2
    Last Post: 12-29-14, 06:45 PM
  3. Copy paste function question for Classic owners
    By Amritv in forum BlackBerry Classic
    Replies: 4
    Last Post: 12-28-14, 10:45 PM
  4. Replies: 2
    Last Post: 12-26-14, 04:09 PM
  5. why my blackberry 9930 did not open internet ?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-26-14, 02:21 PM
LINK TO POST COPIED TO CLIPBOARD