• 00Days
  • 00Hours
  • 00Mins
  • 00Secs
Check out the best deals!
02-21-18 01:27 PM
171 123 ...
tools
  1. Kra Lex's Avatar
    Hello guys, i really really want to buy a bb classic because im fed up with using the iphone so i really need to know if the classic will run whatsapp in 2018..
    12-19-17 03:20 PM
  2. phone-company's Avatar
    Yes it will still work in 2018 if you use the Android apk and a little app call "whatsfixer" from BB World. The original whatsapp from BB World is shut down by the end of 2017

    Posted via CB10
    ARQ-Keighley likes this.
    12-19-17 03:24 PM
  3. Kra Lex's Avatar
    So i can also use 100% the apk? I will not be blocked by whatsapp for using an „inofficial“ app?
    12-19-17 03:52 PM
  4. arfeo's Avatar
    Yes, you 100% can use it. And yes - it is 1000% __official__ app.

    Posted via CB10
    DreadPirateRegan likes this.
    12-19-17 04:09 PM
  5. conite's Avatar
    Hold on.

    It's not fully functional (there are some limitations), and it too could stop working at any moment.
    Bbnivende likes this.
    12-19-17 04:25 PM
  6. arfeo's Avatar
    Hold on.

    It's not fully functional (there are some limitations), and it too could stop working at any moment.
    I am pretty sure it - Android apk - will work until 12/31/2019.

    Posted via CB10
    12-19-17 04:31 PM
  7. conite's Avatar
    I am pretty sure it - Android apk - will work until 12/31/2019.

    Posted via CB10
    Not necessarily.

    It will support 100% compatible Jellybean for a couple of years, but there are countless other failure points to the BB10 Android Runtime than just the API level.
    12-19-17 04:33 PM
  8. arfeo's Avatar
    You definitely should tell me - an android apps dev - about that...

    Posted via CB10
    Last edited by arfeo; 12-19-17 at 05:00 PM.
    12-19-17 04:40 PM
  9. Kra Lex's Avatar
    Im confused now, shouldnt i buy a bb classic now? Or should i just wait for 1.1.18 so i can look if it works?
    12-19-17 04:50 PM
  10. arfeo's Avatar
    Im confused now, shouldnt i buy a bb classic now? Or should i just wait for 1.1.18 so i can look if it works?
    If you really want __Classic__, and WA is the only unknown - then go and buy one, it is beautiful. WA will work, for a couple years at least, I almost guarantee that. But if you are just passing by thinking of Classic or smth else maybe..., then you'd probably buy another purely Android device.

    Posted via CB10
    12-19-17 04:59 PM
  11. conite's Avatar
    Im confused now, shouldnt i buy a bb classic now? Or should i just wait for 1.1.18 so i can look if it works?
    If WhatsApp is a critical function, then BB10 is a bad choice.
    12-19-17 05:03 PM
  12. Invictus0's Avatar
    You definitely should tell me - an android apps dev - about that...

    Posted via CB10
    The developer behind the BB10 client (a WhatsApp employee) has stated they won't block BB10 users from using the Android app but it can stop working at any time because it's not being tested on the runtime (the Android runtime isn't a 1:1 implementation). It doesn't fully work as is without a fix and even then there are still broken features.

    https://forums.crackberry.com/blackb...l#post12498335

    If you need WhatsApp, definitely skip BB10.
    12-19-17 05:25 PM
  13. Kra Lex's Avatar
    If you really want __Classic__, and WA is the only unknown - then go and buy one, it is beautiful. WA will work, for a couple years at least, I almost guarantee that. But if you are just passing by thinking of Classic or smth else maybe..., then you'd probably buy another purely Android device.

    Posted via CB10
    I want the bb classic so bad because its a little bit legendary and the problem is that i spend way too much on my iphone like youtube and other social media sites i have to reduce that, and the classic is perfect for me i can check my mails daily and i also need whatsapp because of groups etc.
    12-19-17 05:57 PM
  14. Kra Lex's Avatar
    I have no other alternatives to say the truth... the smartphobes today all are too big for my taste and they are all inviting me to waste my important time😁
    12-19-17 06:00 PM
  15. arfeo's Avatar
    I have no other alternatives to say the truth... the smartphobes today all are too big for my taste and they are all inviting me to waste my important time😁
    If so, buy a classic and enjoy WA as long, as you can. Classics are available today at very decent prices. If someday in a year or two WA suddenly stops, you will move on another smartphone and begin wasting your time.

    As for me: a couple years of owning a device which I truly love worth $70-100. I spend much more money on coffee in that period of time.

    Posted via CB10
    Last edited by arfeo; 12-20-17 at 02:12 AM.
    12-20-17 01:06 AM
  16. arfeo's Avatar
    The developer behind the BB10 client (a WhatsApp employee) has stated they won't block BB10 users from using the Android app but it can stop working at any time because it's not being tested on the runtime (the Android runtime isn't a 1:1 implementation). It doesn't fully work as is without a fix and even then there are still broken features.

    https://forums.crackberry.com/blackb...l#post12498335

    If you need WhatsApp, definitely skip BB10.
    To be said I practically don't use WA on my passport, I am a heavy Telegram user. Nevertheless when I do, I don't see any features broken. I can send text messages, I can make calls and share media files with my contacts. If devs do support Android 4, and features are working today, I cannot imagine why they could be broken tomorrow, if Android 4 is still supported. Maybe, some features don't work already today, but I cannot detect which.

    Posted via CB10
    Last edited by arfeo; 12-20-17 at 01:42 AM.
    12-20-17 01:27 AM
  17. ARQ-Keighley's Avatar
    Yes it will still work in 2018 if you use the Android apk and a little app call "whatsfixer" from BB World. The original whatsapp from BB World is shut down by the end of 2017

    Posted via CB10
    >> Morning ( UK time ). Is there any chance you could help by posting the link &/or full instructions to get What'sApp via android services functioning on bb10 devices? If you can, please ensure they are the most current instructions. Many thanks.

    >> Also, once installed, can the new google app version refer/sync to the bb10 one or how do you recommend porting the old app conversations to the new google version for What'sApp?

    Look forward to your feedback. As time is short (i.e. today is the 20th of December 2017.

    ARQ
    12-20-17 01:51 AM
  18. the_boon's Avatar
    Don't forget that you also must have an SD card as well for the Android apk + whatsfixer to work. Basically, all sent and received media (photos, videos, voice notes) will be automatically stored on the SD.

    However, like conite said, this solution is only viable as long as WhatsApp developers continue support for the Android 4.3 version (which is the version that all BB10 devices are stuck on). But I'd say it should be good enough for 2018. Beyond that, anything can happen.
    ARQ-Keighley likes this.
    12-20-17 02:32 AM
  19. Kra Lex's Avatar
    So i looked on the website from whatsapp what the minimum requirement is and 2.3.3 is the minimum. So i can use classic for whatsapp without doubts because it has 4.3
    12-20-17 02:53 AM
  20. Kra Lex's Avatar
    When the classic will not work i guess i will have to buy the keyone ( which also looks damn cool) but i guess i have to deal with de fact that i should not waste my time woth it
    12-20-17 02:58 AM
  21. unichips's Avatar
    To be said I practically don't use WA on my passport, I am a heavy Telegram user. Nevertheless when I do, I don't see any features broken. I can send text messages, I can make calls and share media files with my contacts. If devs do support Android 4, and features are working today, I cannot imagine why they could be broken tomorrow, if Android 4 is still supported. Maybe, some features don't work already today, but I cannot detect which.

    Posted via CB10
    The day will inevitably come when WhatsApp decides that they don't want to hold back development of the Next Big Thing (TM) due to the complexity of implementing it while remaining compatible with Android 4.x.

    When that day comes, they will set the minimum Android runtime to some newer version, and deprecate support for older versions of Android the same way that they have deprecated other older operating systems. That means any new versions of the app will be incapable of running on older Android devices.

    However, the older version of the app won't just automatically stop working. Instead, it will continue attempting to work the same way as it always used to. Its success in those attempts will depend upon the continued availability of legacy communication protocols (both in WhatsApp's central servers, and in its end-to-end peer device connections). Eventually, the time will come when WhatsApp will decide to modify its central servers or peer-to-peer protocols in a non-backwards-compatible way. When that happens, the final version of WhatsApp for Android 4.x will actually cease to function.

    (This non-backwards-compatible protocol change has happened at least once already, for example, when they moved end-to-end encryption from optional to mandatory. I strongly suspect it's happening again right now, leading to the ultimate result of the BB10 app ceasing to function.)
    12-20-17 09:55 AM
  22. Invictus0's Avatar
    To be said I practically don't use WA on my passport, I am a heavy Telegram user. Nevertheless when I do, I don't see any features broken. I can send text messages, I can make calls and share media files with my contacts. If devs do support Android 4, and features are working today, I cannot imagine why they could be broken tomorrow, if Android 4 is still supported. Maybe, some features don't work already today, but I cannot detect which.

    Posted via CB10
    Well the main issue is the fix is required because of how the runtime stores files locally on the device. Even with it applied, users are reporting problems with the Status feature and sending videos over a certain size or length. It may not be an issue for many but it's certainly something heavy users will run into.

    So i looked on the website from whatsapp what the minimum requirement is and 2.3.3 is the minimum. So i can use classic for whatsapp without doubts because it has 4.3
    There's more to it than the version of Android that's supported, the runtime in BB10 isn't full Android so not all apps will work correctly. WhatsApp will work with some tinkering but the developer has warned it could stop working at any time because they aren't testing the app on BB10.
    BigAl_BB9900 likes this.
    12-20-17 10:15 AM
  23. the_boon's Avatar
    I thought it was just a question of Android version, whether it's the runtime on a BB10 device or a stock Android device.
    Someone above mentioned that right now, WhatsApp supports Android 2.3.3 and up. Doesn't that mean that it should be good to go as long as that minimum support doesn't get to 4.4 (KitKat)?
    12-20-17 10:21 AM
  24. Chuck Finley69's Avatar
    I thought it was just a question of Android version, whether it's the runtime on a BB10 device or a stock Android device.
    Someone above mentioned that right now, WhatsApp supports Android 2.3.3 and up. Doesn't that mean that it should be good to go as long as that minimum support doesn't get to 4.4 (KitKat)?
    Apparently there's some compatability issues sometimes behind the scenes between Android OS with BB10 OS....
    12-20-17 10:27 AM
  25. conite's Avatar
    I thought it was just a question of Android version, whether it's the runtime on a BB10 device or a stock Android device.
    Someone above mentioned that right now, WhatsApp supports Android 2.3.3 and up. Doesn't that mean that it should be good to go as long as that minimum support doesn't get to 4.4 (KitKat)?
    Look at Instagram. It worked fine on BB10 up to Instagram v10.3.2, then all subsequent versions crash with no change to the Android API level. That happened overnight.
    12-20-17 10:39 AM
171 123 ...

Similar Threads

  1. The android passport exists in China? Not just a spam post.
    By IvanTheTolerable in forum BlackBerry Passport
    Replies: 14
    Last Post: 01-18-18, 03:55 AM
  2. Android WhatsApp - No numbers and symbols on keyboard?
    By David8974 in forum BlackBerry Passport
    Replies: 10
    Last Post: 12-22-17, 07:20 PM
  3. AAR649 on AT&T
    By celticmagick in forum BlackBerry KEYone
    Replies: 12
    Last Post: 12-20-17, 08:25 AM
  4. PSA: Gain an Unfair Advantage in Puzzle Fighter
    By q335r49 in forum BlackBerry KEYone
    Replies: 1
    Last Post: 12-19-17, 03:53 PM
  5. On my blacberry the system was down. What should i do?
    By CrackBerry Question in forum Ask a Question
    Replies: 1
    Last Post: 12-19-17, 10:32 AM
LINK TO POST COPIED TO CLIPBOARD