07-13-15 10:19 PM
32 12
tools
  1. Kdm31091's Avatar
    Just got my Classic a few days ago and I love it. I'm on Verizon and my software is 10.3.1.941.

    I have a texting problem which others have mentioned in past threads. I want to know if there is any fix for it. It happens several times a day especially when I'm in my basement. An SMS text will not send, and gets stuck on the "transmitting" icon. Any further texts after that get stuck on the "clock". I can wait for many minutes, and they won't send, even if I go to a better reception area. The only option is to reboot the phone, which needless to say, is cumbersome to do every hour and seems to drain the battery a bit everytime I do it.

    I love this phone -- but this issue is enough to frustrate me away from it. It's simply unacceptable to not be able to reliably send texts. Does anyone know of a fix? I can try and contact Verizon, but with their track record I doubt they will do anything to help me.
    04-19-15 09:33 AM
  2. kbz1960's Avatar
    You could try a different OS or try a different radio file using an autoloader.
    04-19-15 09:42 AM
  3. Kdm31091's Avatar
    I don't expect a detailed walkthrough, but can you give me a general idea of how I go about doing that? (either the OS or the autoloader)
    04-19-15 09:43 AM
  4. kbz1960's Avatar
    For the OS you can make a blitz file which is not destructive or do an autoloader which is. For the radio it's not destructive.

    The radio autoloaders can be found here.

    https://drive.bitcasa.com/send/6tMMp...TiFBWPmbGMaig/

    For the OS you can get the files from here.

    http://forums.crackberry.com/bb10-le...links-1012656/

    And can make your own blitz following this, just replace the OS with the one your using.

    How to use the files posted in the first post of this thread?

    Following the steps below you can upgrade to 10.3.1.1151 non-destructively, so you won't lose any data on your device and do not have to start from scratch.
    It's like doing an OTA update on your device.

    Note that this tutorial is assuming that you are using Windows and have the latest version of BlackBerry Link installed.

    Before you do anything backup your device with BlackBerry Link.
    Do a full backup!
    If something goes wrong you can easily go back to your current OS and restore your backup.

    Backup made?
    Then close BlackBerry Link and proceed:

    1)
    Install the latest version of Sachesi
    Currently 2.0.0 RC from here
    https://github.com/xsacha/Sachesi/releases

    2)
    Download the 3 leaked files for your device:
    Radio
    Core OS
    Debrick
    from the first post of this thread.
    Make sure that you download the proper files for your device, in this example it is a Z10-STL100-2

    The smallest file is the Radio and looks like:
    qc8960-10.3.1.1152-nto+armle-v7+signed.bar

    The biggest file is the Debrick and looks like:
    qc8960.factory_sfi.desktop-10.3.1.1151-nto+armle-v7+signed.bar

    The third file is the Core OS and looks like:
    qc8960.factory_sfi-10.3.1.1151-nto+armle-v7+signed.bar

    3)
    Create a folder on your hard drive
    Name it as the OS you have downloaded, e.g.
    10.3.1.1151

    4)
    Create a second folder on your hard drive
    Name it
    10.3.1.1151 Debrick

    5)
    Put the Core OS and the Radio in your 10.3.1.1151 folder

    6)
    Put the Debrick file (the biggest one) in your 10.3.1.1151 Debrick folder

    7)
    Open Sachesi
    You do not have to connect your device yet
    Just open Sachesi and click the tab Extract

    Click the Extract Signed button and select the big Debrick file from your 10.3.1.1151 Debrick folder

    You' ll see a progress bar running, wait till the process is finished.

    In your 10.3.1.1151 Debrick folder is now a second even bigger file which looks like:
    qcfm.image.com.qnx.qcfm.qc8960.factory_sfi.desktop .BB10_3_1.1151.798331.signed

    In Sachesi click on the Extract Apps button and selct this new big .signed file from your 10.3.1.1151 Debrick folder

    You' ll see again a progress bar running, wait till the process is finished.

    In your 10.3.1.1151 Debrick folder is now a subfolder which looks like:
    qcfm.image.com.qnx.qcfm.qc8960.factory_sfi.desktop .BB10_3_1.1151.798331

    Open this folder and copy all files in your formely created 10.3.1.1151 folder (where you put the Core OS and the Radio before)

    8)
    Now put your device in airplane mode and connect it via USB
    If you have set a password on your device enter it.
    Click the Install tab
    Leave the checkmark "Only install newer apps" checked
    Click the Install Folder button and select your 10.3.1.1151 folder
    You will see a progress circle, be patient this will take some time

    9)
    Your device restarts, first boot may take some time

    10)
    Congratulations, you are now running 10.3.1.1151

    11)
    Donate to xsacha for providing the excellent Sachesi software:
    Qtness Development Working on Qt apps
    idssteve likes this.
    04-19-15 11:05 AM
  5. JRuppenthal's Avatar
    Just got my Classic a few days ago and I love it. I'm on Verizon and my software is 10.3.1.941.

    I have a texting problem which others have mentioned in past threads. I want to know if there is any fix for it. It happens several times a day especially when I'm in my basement. An SMS text will not send, and gets stuck on the "transmitting" icon. Any further texts after that get stuck on the "clock". I can wait for many minutes, and they won't send, even if I go to a better reception area. The only option is to reboot the phone, which needless to say, is cumbersome to do every hour and seems to drain the battery a bit everytime I do it.

    I love this phone -- but this issue is enough to frustrate me away from it. It's simply unacceptable to not be able to reliably send texts. Does anyone know of a fix? I can try and contact Verizon, but with their track record I doubt they will do anything to help me.
    This is troubling, since I'm thinking of getting a Classic when I switch over to Verizon in the next couple of weeks. Is this a common problem for others VZW users? If it is, I might have to go with the Z30 since I have to have reliable SMS.
    04-19-15 11:10 AM
  6. tdyhedge's Avatar
    I had the exact same problem with my VZ Classic when I first bought it. I've had mine for a little over a month now. I loaded a newer OS on it after about third day of having it, and it's been solid ever since. However I did get the same failed to send text message thing just out of the blue, the other day but a restart fixed it and it's been good ever since. Man, was it frustrating before but no other issues. My advice, go ahead and get the Classic, update the OS before doing anything else to it, and you'll be fine.

    Posted via CB10
    04-19-15 11:16 AM
  7. Kdm31091's Avatar
    OK, I installed the above update and my device is booting now. We'll see if it helps, I will post back
    kbz1960 likes this.
    04-19-15 01:53 PM
  8. kbz1960's Avatar
    Hope it helps!
    04-19-15 02:51 PM
  9. Kdm31091's Avatar
    Ugh, nope, didn't help. I still have the same issue. I know the update went through, because my boot screen says BB Classic instead of just BB and I now have the BB meetings app that wasn't there before.

    Are there any other potential solutions to this?
    04-19-15 09:21 PM
  10. kbz1960's Avatar
    You can try an older radio. I'm surprised as I've had no issues on that OS, I did have on earlier ones.
    04-19-15 09:26 PM
  11. Kdm31091's Avatar
    Is the process for putting an older radio on the same as the above and just omitting the Core OS files?
    04-19-15 09:32 PM
  12. kbz1960's Avatar
    I get that blame frequently... of course it's my wife lashing out at me. Of course, she didn't mind when I ordered her the pink crystal case for her Pearl.
    No. They are exe files that will run and install only the radio files.
    04-19-15 10:02 PM
  13. momofteme's Avatar
    In my basement where the signal is weak, my q10 would have to be restarted to send the stuck message.

    My wife's Z30 would do the same.

    My classic will eventually send them but it can take a while.

    In my area Verizon is having issues, because there are places in the house where I get no service at all where I used to have good service. Maybe a call to Verizon would help.

    Posted via CB10
    04-20-15 07:52 AM
  14. Kdm31091's Avatar
    You're right. I may just have to call them. I don't know what they can do about it, but we'll see. I already have a signal booster in my basement. That does seem to have helped with call quality and not dropping calls in the basement, but it hasn't really changed anything with texting
    04-20-15 08:11 AM
  15. Kdm31091's Avatar
    Spoke to Verizon. They were somewhat helpful. They had me power off and they reset the provisions on my line, or something, whatever that means.

    We'll see if it helps. This issue doesn't always occur, so it takes time to see if any fix works. If not, guess I'll be loading an older radio. The ironic part is that calls from the basement are great and this phone gets better reception overall in my house than my androids ever did.
    04-20-15 09:02 AM
  16. davisgq's Avatar
    This is troubling, since I'm thinking of getting a Classic when I switch over to Verizon in the next couple of weeks. Is this a common problem for others VZW users? If it is, I might have to go with the Z30 since I have to have reliable SMS.
    I'm on VZW using a Classic and haven't yet run into this issue. And I text a LOT.
    04-20-15 09:20 AM
  17. Arun Baheti's Avatar
    I'm having the same issue. Just started for me last week. In my case, I've waited up to 24 hours and the messages just never get sent, stay stuck. I did do a solid power down twice and it helped, but now the problem is back again. Very frustrating. Strangely, I am able to receive texts just fine. Anyone figure out how to solve this without having to reboot every time?

    I'm in LA, in an neighborhood where my once stunning coverage went to terrible about 18 months ago (when they did something to the local towers, I assume, maybe the 4g LTE rollout?). I also have an extender from Verizon (but still get a ton of dropped calls, but that's another story).

    Loving the phone, but this issue is very annoying.

    --Arun Baheti
    04-23-15 06:54 PM
  18. Kdm31091's Avatar
    The problem is still occurring for me and having to reboot a few times a day. I'll try Verizon again, but evidently they don't really have a solution. It's clearly not a software issue as I have tried different OS versions and it doesn't seem to matter.
    04-23-15 09:05 PM
  19. Arun Baheti's Avatar
    So you think it is with the Verizon network somehow? One other thing I notice is that I swear I have to reboot twice for it to resolve each time. I still continue to receive SMS just fine.

    I haven't done any software updates recently and it just started for me last week. I am trying an experiment today which is to switch to forced MMS mode vs automatic selection. I'm wondering if MMS will work more reliably. Not ideal, but if it works I'll live.

    --arun
    04-24-15 12:25 PM
  20. Kdm31091's Avatar
    It has to be the network IMO, since the software seems to make no difference.

    Let me know if the MMS thing works
    04-25-15 06:17 PM
  21. Arun Baheti's Avatar
    Several days forcing MMS and have not had the outbound problem yet. Messages take a little longer to send, but they do go through. Delivery icon works too (possible also with non-Verizon contacts too? Not sure). I'll experiment with SMS again in a day or two, but for now MMS looks like it works. YMMV. If anyone has an explanation or a more scientific answer, please advise.
    04-27-15 04:25 PM
  22. applezapp's Avatar
    Hello. Thanks for everyone's follow-ups - much appreciated.

    I too have the BB Classic on the Verizon network. And I'm having the same 'hanging' SMS outbound text messages problem. I have found no solutions.

    I'm asking AT&T customers to chime in - do you have this same problem? This feedback may help narrow the issue to the Verizon service versus BB Operating System versus BB hardware.

    Thanks in advance. I really want to love this phone, but rebooting to send my text messages just won't cut it....I'm sure everyone agrees.

    Matt
    04-27-15 06:07 PM
  23. skuzz's Avatar
    FWIW I have tried the unlocked Classic on AT&T and T-Mobile. It doesn't seem to have the SMS issue, instead when it has gone through a no service or low signal area it goes into a death dive where the system idle process eats cpu cycles, it becomes physically warm and the battery drains in a few hours. Tried another GSM unlocked and same problem. Reboot solves the battery drain loop. It even shows up on the energy usage graph.

    Our Verizon classic manifests the same SMS issue as mentioned above and only a reboot solves it. Really disappointed fixes haven't been issued.
    05-10-15 04:11 PM
  24. jfolland's Avatar
    I've had to restart my Classic 3 times today due to this issue.

    Posted via CB10 on my Big Red Classic!
    05-11-15 04:52 PM
  25. Arun Baheti's Avatar
    For what it is worth, forced MMS vs SMS has worked well for a week and counting on my Verizon Classic. Don't understand it, but am not questioning it. I'll try reverting to normal mode vs forced MMS later this week and see if there is a difference.
    05-11-15 04:58 PM
32 12

Similar Threads

  1. Best Blackberry device on Verizon?
    By JRuppenthal in forum BlackBerry Classic
    Replies: 13
    Last Post: 04-21-15, 12:20 PM
  2. Verizon Classic battery life?
    By JRuppenthal in forum BlackBerry Classic
    Replies: 11
    Last Post: 04-20-15, 12:38 PM
  3. Q10 Software & Hardware Issues - is it functional?
    By Trauma Surgeon in forum BlackBerry Q10
    Replies: 3
    Last Post: 04-19-15, 02:17 PM
  4. Best Blackberry device on Verizon?
    By JRuppenthal in forum BlackBerry Passport
    Replies: 4
    Last Post: 04-18-15, 07:05 PM
  5. WiFi Issue on 10.3.1
    By skstrials in forum BlackBerry 10 OS
    Replies: 2
    Last Post: 04-17-15, 09:32 PM
LINK TO POST COPIED TO CLIPBOARD