1. Benjamin Black's Avatar
    I would love to next check. What's your most resonable price?

    Double typin' classicly
    $135 shipped

    Posted via BlackBerry Passport Silver Edition
    09-13-15 11:30 AM
  2. GraCal's Avatar
    Kraken, DT is fixed. The updated OS (.2629) released last week corrected it. Look through the "Update/Leak" Forum, it is all over the place and very easy to do.

    Posted via CB10
    09-13-15 11:47 AM
  3. doublehighc's Avatar
    Had my Classic since March. Started double typing about two months ago. Finally sent it back to Verizon and current one seems good so far.

    Posted via CB10
    09-14-15 08:55 AM
  4. Ldgarcia4283's Avatar
    Got my qi charger and it's awesome.

    Posted via CB10
    3_M4N likes this.
    09-14-15 07:45 PM
  5. Kraken72's Avatar
    Kraken, DT is fixed. The updated OS (.2629) released last week corrected it. Look through the "Update/Leak" Forum, it is all over the place and very easy to do.

    Posted via CB10

    I'd love to load up a lleak but I currently don't havee a computer.

    Double typin' classicly
    Benjamin Black likes this.
    09-15-15 03:26 PM
  6. Benjamin Black's Avatar
    I'd love to load up a lleak but I currently don't havee a computer.

    Double typin' classicly
    My classic is cheaper than a new computer

    Posted via BlackBerry Passport Silver Edition
    09-15-15 05:15 PM
  7. Baritone Astoria's Avatar
    Any of you guys have trouble reconnecting to the network when leaving an area with no service?

    I tried swapping a SIM card this week and it didn't seem to completely resolve my problem. I am not sure if it's just a weak signal that is preventing my Classic from connecting to the network or if the phone is bad. It's a new phone.

    Any ideas/help appreciated.
    09-16-15 01:44 PM
  8. davisgq's Avatar
    Any of you guys have trouble reconnecting to the network when leaving an area with no service?

    I tried swapping a SIM card this week and it didn't seem to completely resolve my problem. I am not sure if it's just a weak signal that is preventing my Classic from connecting to the network or if the phone is bad. It's a new phone.

    Any ideas/help appreciated.
    Sometimes. I find that I have to turn off the Mobile Network and then turn it back on and then I get a connection again. Doesn't happen that frequently thank goodness.

    Posted via CB10
    09-16-15 01:47 PM
  9. Baritone Astoria's Avatar
    Sometimes. I find that I have to turn off the Mobile Network and then turn it back on and then I get a connection again. Doesn't happen that frequently thank goodness.
    Posted via CB10
    Boy, am I glad to read that!! Thanks for sharing! I have the same exact issue.

    About how often does it happen to you?
    09-16-15 05:21 PM
  10. davisgq's Avatar
    Boy, am I glad to read that!! Thanks for sharing! I have the same exact issue.

    About how often does it happen to you?
    That's a good question. It happened twice last week. For whatever reason it did reconnect to the network today after about a second or two. Almost always when disconnecting from Wi-Fi. Though a few weeks ago, I was traveling to Albany and it had trouble with connecting to 4G LTE so I had to turn it off and then back on. I guess it happens more than I thought but again, it doesn't really do it so much to be an annoyance.

    Posted via CrackBerry App
    Baritone Astoria likes this.
    09-16-15 09:33 PM
  11. Baritone Astoria's Avatar
    That's a good question. It happened twice last week. For whatever reason it did reconnect to the network today after about a second or two. Almost always when disconnecting from Wi-Fi. Though a few weeks ago, I was traveling to Albany and it had trouble with connecting to 4G LTE so I had to turn it off and then back on. I guess it happens more than I thought but again, it doesn't really do it so much to be an annoyance.

    Posted via CrackBerry App
    Yes, mine also almost always happens when I am disconnecting from Wifi.
    09-16-15 10:29 PM
  12. Benjamin Black's Avatar
    When was the last time you guys got new sim cards? Do you take your sim in and out of your phone often? I have experienced multiple times what you guys described due to a less than pristine sim card.

    Posted via BlackBerry Passport Silver Edition
    09-16-15 11:02 PM
  13. Baritone Astoria's Avatar
    When was the last time you guys got new sim cards? Do you take your sim in and out of your phone often? I have experienced multiple times what you guys described due to a less than pristine sim card.

    Posted via BlackBerry Passport Silver Edition
    I swapped my SIM two days ago. And the old one was only a week old!

    Yesterday I swapped my classic for a new one. Fingers crossed!
    09-17-15 06:21 AM
  14. Baritone Astoria's Avatar
    Well my new phone has the same exact problem. I went into work, lost service, then went outside to reconnect and only got a 4glte (NOT a 4GLTE) icon and no blackberry icon. I waited 3 min and it would not fully connect. Then I switched on airplane mode to disconnect manually, turned it right back off. BANG! The network (4GLTE) with 5 bars and the Blackberry icon popped right up!

    I called Verizon and they are going to refresh the phone but they have tried that twice before and that has not resolved the problem. They are also creating a ticket for this issue to be addressed on a higher level.

    If any of you have had this problem, please post it here? Or if any of you do not have this problem, please post here? Since this is a Verizon-specific issue (I had an AT+T classic before and never had this issue) I figure this thread is the best place to get more info.

    Thanks!
    09-17-15 08:50 AM
  15. davisgq's Avatar
    When was the last time you guys got new sim cards? Do you take your sim in and out of your phone often? I have experienced multiple times what you guys described due to a less than pristine sim card.

    Posted via BlackBerry Passport Silver Edition
    My Classic is about 5 months old. Came with a new SIM at the time. After I opened the SIM tray and put it in, I've never taken it out. Ever. Lol. I actually forgot that there WAS a SIM tray Maybe it's time that I do, just to check it out and make sure. The SIM card tray on my Classic IS just a little loose, unlike the SD card slot. But personally, it really doesn't bother me to the point of delusion or frustration.
    09-17-15 10:53 AM
  16. Baritone Astoria's Avatar
    Any of you Verizon Classic users get the recent software update yet?

    I still have 10.3.2.556. It's a company phone.

    Posted via CB10
    05-03-16 05:56 PM
  17. Trist's Avatar
    Any of you Verizon Classic users get the recent software update yet?

    I still have 10.3.2.556. It's a company phone.

    Posted via CB10
    Same. Using 556 w/o a problem. Considering newest update causes battery drain, I don't think it's worth it.

    Posted via CB10
    05-03-16 10:01 PM
  18. pineconeinc's Avatar
    No double typing issue. I swapped to the Classic from an iPhone 6S and purchased it from Verizon a month ago and no problems so far.
    05-05-16 02:37 AM
  19. Baritone Astoria's Avatar
    Same. Using 556 w/o a problem. Considering newest update causes battery drain, I don't think it's worth it.

    Posted via CB10
    Good point!

    I may buy a personal Verizon Classic. Does anyone know if the new ones come with the newest software automatically? Would it be possible to revert back to the older ones?

    Posted via CB10
    05-05-16 05:06 AM
  20. pineconeinc's Avatar
    Good point!

    I may buy a personal Verizon Classic. Does anyone know if the new ones come with the newest software automatically? Would it be possible to revert back to the older ones?

    Posted via CB10
    Mine came with the newest software, I purchased at a Verizon Corporate store. Out of the 15 corporate stores in my area, only one store located in the business district carries the Classic. No Z30's at any of the stores.

    As far as the software, I'm not sure if it can be downgraded. I know I used to be able to downgrade, but that was the old Blackberry devices like the 9900 and the 8350i .

    I'll let you know if you can downgrade, I'll check when I get home if someone else doesn't answer it before then.
    Baritone Astoria likes this.
    05-05-16 01:15 PM
  21. Trist's Avatar
    Mine came with the newest software, I purchased at a Verizon Corporate store. Out of the 15 corporate stores in my area, only one store located in the business district carries the Classic. No Z30's at any of the stores.

    As far as the software, I'm not sure if it can be downgraded. I know I used to be able to downgrade, but that was the old Blackberry devices like the 9900 and the 8350i .

    I'll let you know if you can downgrade, I'll check when I get home if someone else doesn't answer it before then.
    I think I read somewhere in CB that you can't downgrade

    Posted via CB10
    05-05-16 02:20 PM
  22. rthonpm's Avatar
    You can downgrade to another 10.3.2 version, but you cannot go to a lower version than that.

    Posted via CB10
    05-05-16 08:12 PM
  23. Baritone Astoria's Avatar
    I plan to get a Classic through Verizon sometime in the next 6 months or so. Anyone know the likelihood of Verizon discontinuing the Classic? I asked at a corporate store, even the manager, this weekend, but he had no idea.
    05-08-16 09:14 AM
  24. Baritone Astoria's Avatar
    Mine came with the newest software, I purchased at a Verizon Corporate store. Out of the 15 corporate stores in my area, only one store located in the business district carries the Classic. No Z30's at any of the stores.
    How is your battery life so far? Getting a full day on one charge?
    05-08-16 09:19 AM
  25. Trist's Avatar
    I plan to get a Classic through Verizon sometime in the next 6 months or so. Anyone know the likelihood of Verizon discontinuing the Classic? I asked at a corporate store, even the manager, this weekend, but he had no idea.
    No idea. But I bought a week old Classic in perfect condition for half the retail price on ebay. Of course, no warranty, but hey I saved $200! So far it's been 1 month and I don't have any issues with it.

    Posted via CB10
    05-09-16 09:58 AM
104 12345

Similar Threads

  1. Replies: 12
    Last Post: 03-25-18, 02:31 AM
  2. Rogers 10.3.1 on Verizon
    By randy050 in forum BB10 Leaked/Beta OS
    Replies: 6
    Last Post: 05-31-15, 08:07 PM
  3. Verizon BlackBerry Z30 STA100-3 with accessories
    By TLD1 in forum Buy, Sell, Trade - Sold / Archived
    Replies: 12
    Last Post: 05-31-15, 04:47 PM
  4. Questions about upgrading from a 9900 to the Classic or Passport, can I please get some help?
    By CrackBerry Question in forum General BlackBerry Discussion
    Replies: 2
    Last Post: 05-29-15, 05:50 AM
  5. Blue BlackBerry Classic
    By MrNiceNasty527 in forum BlackBerry Classic
    Replies: 3
    Last Post: 05-29-15, 04:15 AM
LINK TO POST COPIED TO CLIPBOARD